Snort won't start on 2.0



  • I installed Snort today and am having issues getting Snort to run. I bought the $29.99 ruleset and updated Snort.

    However, I can not get Snort to start. I click on the green triangle but nothing happens. Any help would be appreciated.



  • What does your system log tab show?



  • Go to updates and update the databases.

    Then go to global settings and select some categories/rules.

    Then try turning it on again.



  • Any chance you have RC2 of pfSense 2.0?

    http://forum.pfsense.org/index.php/topic,37557.0.html



  • I've had the same problem on my boxes since the build from the 18th I think. System log shows

    snort[56413]: FATAL ERROR: /usr/local/etc/snort/snort_37799_bce0/snort.conf(327) Unknown output plugin: "alert_pf"

    It worked fine until I went and changed some rules. Removing that alert from the config file obviously clears the error but it still wont start although the logs indicate it has.

    Yes I have reinstalled and done a clean build but the issue persists.



  • Same here. Since 18th snort refuses to start. I found lots of errors regarding the config-file, but after changing the offending entries, still doesn'T start. But at console it starts and then shows as started in the webgui.
    When i try to start (restart) snort via Webgui, still refuses to start. I have it disabled at the moment. :(


Locked