WEB GUI "dashboard" layout not right / 2.0-RC3 0622 005029 >> Solved



  • Hi,

    With 2.0-RC3 I found the WEB GUI Dashboard layout changes from reload to reload, or items is not showing them self in correct place.

    I have tried with the following browsers, firefox4 (mac/win), stainless (mac), camino (mac), safari (mac/win) and IE9.

    Attached screenshot shows example from Dashboard where "services status" is shown twice.

    Not a big issue, but wanted to report/share to see if others got same issue.

    BR// Steen

    ![pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 705am.jpg](/public/imported_attachments/1/pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 705am.jpg)
    ![pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 705am.jpg_thumb](/public/imported_attachments/1/pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 705am.jpg_thumb)


  • Banned

    I have installed the dashboard package (widescreen)

    Small issues….. :'(

    ![FF_dashboard (Large).jpg](/public/imported_attachments/1/FF_dashboard (Large).jpg)
    ![FF_dashboard (Large).jpg_thumb](/public/imported_attachments/1/FF_dashboard (Large).jpg_thumb)
    ![IE_dashboard (Large).jpg](/public/imported_attachments/1/IE_dashboard (Large).jpg)
    ![IE_dashboard (Large).jpg_thumb](/public/imported_attachments/1/IE_dashboard (Large).jpg_thumb)



  • Hi Brian,

    Many thanks for the suggestion.

    Installed the widescreen option, but from attached screenshot it did not fix the layout issue.
    The System Status box is still repeated twice, I also seen the System Status box been split into two parts 1 the top line (heading text) in one place 2 the information part in other place.

    BR// Steen

    ![pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 841am WS.jpg](/public/imported_attachments/1/pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 841am WS.jpg)
    ![pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 841am WS.jpg_thumb](/public/imported_attachments/1/pfsense 2.0-RC3 Dashboard Screenshot SH 22062011 841am WS.jpg_thumb)


  • Rebel Alliance Developer Netgate

    Can you show the "widgets" section of your config.xml?

    Odds are that somehow that section is not correct in some way. Removing that part of the config and restoring would reset the dashboard and then you could rearrange the widgets again from there.


  • Rebel Alliance Developer Netgate

    Diagnostics > Backup/Restore, download a config backup from there.

    Or if you want to look at the file directly, it's in /conf/config.xml



  • Hi jimp,

    Found two locations each with a config.xml file.

    Location 1 = /cf/conf  attached file 01
    Location 2 = /conf.default/  attached file 02

    From what I understand on you its the file in location 1 ( /cf/conf ) I should either edit or restore.

    I'll give it a go and report back.

    BR// Steen

    Oops under restore I do not find any config.xml and when I select Choose File I get to my own computer, what I do wrong?


  • Rebel Alliance Developer Netgate

    Don't attach your entire config here. I removed the attachments. Your certificates and passwords and other data can be in there.

    The one from /cf/conf/ (really /conf/ is easier, goes to the same place) is the right one. Though whatever you opened those xml files in mangled the formatting.

    Here is the widgets section from your config:

    	 <widgets><sequence>system_information-container:col1:show,captive_portal_status-container:col1:close,carp_status-container:col1:close,cpu_graphs-container:col1:close,gateways-container:col1:close,gmirror_status-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:show,interfaces-container:col2:close,ipsec-container:col2:close,load_balancer_status-container:col2:close,log-container:col2:close,picture-container:col2:close,rss-container:col2:close,services_status-container:col2:show,services_status-container:col2:show,traffic_graphs-container:col2:close,openvpn-container:col2:none,wake_on_lan-container:col2:none</sequence></widgets> 
    

    You have somehow managed to get the services status widget in there twice.

    [...],services_status-container:col2:show,services_status-container:col2[...]
    


  • Hi Jim,
    Sorry about the full attachment.

    OK, I removed the widget then the confg.xml looks like this under the widget section:

    <widgets><sequence>system_information-container:col1:show,captive_portal_status-container:col1:close,carp_status-container:col1:close,cpu_graphs-container:col1:close,gateways-container:col1:close,gmirror_status-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:show,interfaces-container:col2:close,ipsec-container:col2:close,load_balancer_status-container:col2:close,log-container:col2:close,picture-container:col2:close,rss-container:col2:close,services_status-container:col2:close,services_status-container:col2:close,traffic_graphs-container:col2:close,openvpn-container:col2:none,wake_on_lan-container:col2:none</sequence></widgets>

    I deleted the extra entry of services_status-container:col2:close and everything seems to be OK, now how this could happen I do not know as before this I had no idea where config.xml was located nor what was in it, but I had lots of strange locks ups and hangs yesterday posted in other post, perhaps some thing there?

    Many thanks!

    Steen


  • Rebel Alliance Developer Netgate

    Hard to say how that happened, though I have seen it only one other time that I remember (someone else on the forum). I think it was one that was upgraded from 1.2.3.

    I've never had it happen to me so I haven't had any chance to narrow it down.



  • :o well the world of software is a mysterious world I am that world but more from implementation point that developer ;)


Locked