I cannot access any websites I host locally, external for every1 else works fine



  • I have recently switched to Pfsense from IPCOP, and everything has been running woderful and I am very impressed with it over all the other firewall packages I have used. But I am having a strange issue, I host a number of websites, and I have multple statip ip addresses, so I host a few sites on each IP using NAT for the ports and all that, some are linux some are win2k3 using host headers or virtual hosts so I can have multiple websites on 1 static IP. So external access is fine, any can access all my sites and services on the proper ports being forwarded to internal servers, but if I try to go to www.whatever.com (only if I host it) I cannot access it, all my web access seems to forward me to the pfsense box ? I am wondering if this is a Rule issue or NAT or what ? If you need any more information or calrification please let me know this is becoming a serious issue for me I cant test any of my domains after doing updates or what not cause I cant see them haha.

    Thanks soo much every1! Pfsense really is the shizzle!

    ** UPDATE **

    Looks like no matter how much I read I still don't absorb sometimes, I believe I found the issue under Advanced settings the last setting.

    Network Address Translation
    Disable NAT Reflection  Disables the automatic creation of NAT redirect rules for access to your public IP addresses from within your internal networks. Note: Reflection only works on port forward type items and does not work for large ranges > 500 ports.

    So it seems everything is working perfect now, thanks so much and sorry to bug every1, I wonder where it says it dosent work for like 500+ ports I hope if I have to forward a wide range for something like asterisk, it will be able to figure things out, I dont think it will ever be an issue though, again thanks soo much!!



  • Try System -> Advanced -> Disable NAT Reflection



  • haha yah I was editing my post when u posted thanks very much for your help!!


Log in to reply