Help My CPU Usage is high



  • Hello Everybody is there something to worry if my cpu usage is reaching aproximately 87% going up but states are stable to 500/10000  Memory usage is 7% and swap size is not increasing is this normal for a single core processor?



  • Yes, no or maybe (depending on what your box is doing: 87% CPU with no traffic passing through would be high but 87% with busy VPNs and running packages such as snort might be expected).

    I suggest you post a screenshot of the output of the pfSense shell commands

    
    # vmstat -i
    # top -S -H
    
    ```(type _q_ when you have the screenshot of top output to quit top.)

  • Netgate Administrator

    Probably worth noting the fact this machine has NICs that are not showing up in pfSense. This could well be the cause.
    http://forum.pfsense.org/index.php/topic,38105.0.html

    Steve



  • vmstat -i

    interrupt                          total      rate
    irq1: atkbd0                          86          0
    irq9: acpi0                    106996860      74666
    irq15: ata1                        4420          3
    irq21: vr0 vr3                      5198          3
    irq22: rl0 vr1                    13552          9
    irq23: vr2                            1          0
    cpu0: timer                      2754581      1922
    Total                          109774698      76604

    top -S -H

    last pid:  9049;  load averages:  1.77,  1.63,  1.14    up 0+00:24:35  13:48:49
    88 processes:  2 running, 67 sleeping, 19 waiting
    CPU:  1.1% user,  0.0% nice,  0.4% system, 88.5% interrupt, 10.1% idle
    Mem: 47M Active, 26M Inact, 30M Wired, 8K Cache, 17M Buf, 889M Free
    Swap: 2048M Total, 2048M Free

    PID USERNAME PRI NICE  SIZE    RES STATE    TIME  WCPU COMMAND
      24 root    -52    -    0K    8K WAIT    18:34 90.19% irq9: acpi0
      11 root    171 ki31    0K    8K RUN      3:31  9.47% idle: cpu0
    9034 root      44    0  3524K  1764K RUN      0:00  0.20% top
      879 root      4    0 44808K 18764K accept  0:14  0.00% php
      875 root      4    0 45832K 20060K accept  0:03  0.00% php
      12 root    -32    -    0K    8K WAIT    0:02  0.00% swi4: clock sio
      871 root      4    0 45832K 19232K accept  0:02  0.00% php
      863 root      4    0  5144K  2936K kqread  0:02  0.00% lighttpd
      867 root      4    0 42760K 16016K accept  0:01  0.00% php
      450 nobody    44    0  3156K  1212K select  0:01  0.00% apinger
    1519 root      8  20  3492K  1420K wait    0:00  0.00% sh
        5 root      -8    -    0K    8K -        0:00  0.00% g_down
      36 root    -68    -    0K    8K WAIT    0:00  0.00% irq22: rl0 vr1
        4 root      -8    -    0K    8K -        0:00  0.00% g_up
    1595 root      8  20  3156K  796K nanslp  0:00  0.00% check_reload_status
      51 root      20    -    0K    8K syncer  0:00  0.00% syncer



  • Your ACPI is broken (over 70,000 interrupts a second).

    Here's interrupt rates from my system (which does have ACPI enabled):

    vmstat -i

    interrupt                          total      rate
    irq0: clk                      143773392        999
    irq1: atkbd0                          96          0
    irq7: ath0 uhci1+              13672559        95
    irq8: rtc                      18401627        127
    irq10: rl0 ehci0                9685262        67
    irq11: vr0 uhci0                4806754        33
    irq14: ata0                      310276          2
    irq15: ata1                          194          0
    Total                          190650160      1325

    Maybe a BIOS update will fix it. Maybe a more up to date build will fix it. Alternatively disable ACPI in the BIOS menu or on startup. You will find some hints on disabling ACPI if you search the forums for ACPI disable.


Locked