Openvpn help and upgrade woes



  • I've been playing with vmware as I want to switch a to a vm setup.  So I finally settled on vmware server, and 2.0rc3.  1.2.3 does not seem to pickup more than 1 cpu no matter what I do (initial livecd picks up 2 cpu's, but after install only 1).
      I wanted to swtich to 64 bit, so i installed 64 bit and then restored from my 1.2.3 backup file.  A total crash on the packages, and pfsense would crash on boot up.
      Anyways, I got 2.0 running nicely on a fresh install.  I restored from my 1.2.3 file on everything except my packages, and everything is running great (manually reinstalled packages, with exception of known snort not starting), except for my openvpn connections.  The restore worked as I did not select packages, but it did not restore my openvpn settings which were working previously. 
      I had a site to site connection setup and working as per a previous tutorial posted on the forums.  I am now in the 2.0 openvpn and it's completely foreign to me.  The certificate is stored in a totally different place, and the settings are changed.    Is there a way to get pfsense to get my open vpn settings back from 1.2.3?  Also, I will be switching to 2.0, but the other side will be 1.2.3 for a while longer, is that an issue?
      If not an easy way, is there a bit of a guide somewhere on how to get the simple site to site setup working on 2.0.  It seems a little daunting right now.  Honestly in 1.2.3, there was just setting the method to shared key, pasting the key, entering the port and setting 1 or 2 checkboxes.  The more complicated road warrior setup that I had running seems leaps and bounds more complex in 2.0, and I was going to leave that for later…
      Can someone point me in the right direction?

    Thanks!



  • First, there are no issues I'm aware of running OpenVPN site to site between 1.2.x and 2 RC3. I have 1.2.2, 1.2.3 and 2 RC3 connecting back to a RC3 setup.

    I don't think there is an up to date "How To" for OpenVPN on 2 yet but you definitely want to install  the client export package as it makes life so much easier. It took me about 20 minutes of experimenting to get the hang of the new layout.


  • Rebel Alliance Developer Netgate

    There are site-to-site howtos on the doc wiki for OpenVPN that also touch on 2.0 configuration.

    If you want to import your 1.2.3 settings, you need to import your whole 1.2.3 config.

    You could edit your 1.2.3 config.xml file and remove the <package>…</package> tags which would stop it from trying to reinstall the packages after restoring. Do not remove the entire <installedpackages>section as on 1.2.x the openvpn config was stored there.</installedpackages>



  • Good idea on the xml fix.  With importing everything it was a dismal crash.
    I'll edit the file and remove package info and see what happens.
      What I really need to do otherwise is try to figure out openvpn in 2.0.  I'll see if the wiki can help me out.  I did not look at it since 1.2.3 to get it running.  I did not think 2.0 info would be there.
      I'll give it a go..

    Thanks for the pointer.

    Any good xlm editor (just notepad)?  I had lots of fun the last time I tried editing those files.


  • Rebel Alliance Developer Netgate

    No need for a full xml editor. Any text editor that understands unix line endings would do fine. (Ultraedit, I'm sure others like Notepad+ and such do as well)


Locked