Is there a config file for the dns forwarder?



  • If there is, where is the location? Was searching for an hour.

    The problem I am having is that nslookup pfsense.home for clients on the captive portal side shows that pfsense.home is on 192.168.2.1 and 192.168.3.1

    My captive portal is on LAN 192.168.3.0, I added HTTPS support for CP and then I added a record (Host:pfsense Domain:home IP:192.168.3.1) to override the forwarder.

    So how do I get rid of 192.168.2.1? Because this is causing a delay for Windows client on the CP side due to network 192.168.2.0 being completely blocked off (I would like to keep it that way).



  • What are 192.168.2.1 and 192.168.3.1? pfSense LAN interface and "captive portal" interface?

    Why do clients on 192.68.3.0 need to access pfsense.home? Why not use distinct names for 192.168.2.1 and 192.168.3.1? Or maybe you could allow 192.168.3.0 to access 192.168.2.1 but not anything else on 192.168.2.0.

    Its not generally a good idea to tweak configuration files for pfSense application since they are generally regenerated from the configuration file maintained by the web GUI at least on every boot.



  • Hello  :)

    What are 192.168.2.1 and 192.168.3.1? pfSense LAN interface and "captive portal" interface?

    That's correct

    Why do clients on 192.68.3.0 need to access pfsense.home?

    I only need devices on the captive portal side to resolve pfsense.home to 192.168.3.1 since that's their gateway and dns. Right now the devices are being told that pfsense.home is on 192.168.2.1 and 192.168.3.1.

    Why not use distinct names for 192.168.2.1 and 192.168.3.1?

    Could you tell me what you meant by this?

    Or maybe you could allow 192.168.3.0 to access 192.168.2.1 but not anything else on 192.168.2.0.

    That's correct, I can enable DNS through to 192.168.2.1 but I would like to avoid this.

    Its not generally a good idea to tweak configuration files for pfSense application since they are generally regenerated from the configuration file maintained by the web GUI at least on every boot.

    I was hoping this wasn't the case  :(

    Thank you for the response, appreciate it.  ;D



  • I have it fix by using the IP of the captive portal gateway under Services>Captive Portal>HTTPS Server Name


Locked