Not more than 2 queues at pfSense2.0-RC3-AMD64???



  • hi guys,

    I have been very happy using pfSense 1.2.3 for years so reading that 2.0 is RC already I decided to give it a try - even if it's just to help you locating bugs.
    Compared to 1.2.3 this version is booting faster and the webinterface is faster as well so I guess you guys are on the right path…

    But unfortunateley I had some issues:

    • Contacting my DynDNS-domain from within my LAN (unsing NAT-reflection) works fine for TCP but not for UDP. This can be repaired in a rough-and-ready way by defining a general redirection from the DynDNS-domain to my lan-server in the DNS-forwarder but using reflection would be a cleaner solution for my scenario cos this way it's impossible to spread several services to different IPs within my LAN. I already mentioned this problem in this thread.

    • I defined several queues via the wizard and assigned traffic to them with floating rules. This works fine for my p2p-queue, catching all traffic from one IP running the torrent-client within my lan. But the creation of any further rules are ignoed. Even copying this working p2p-rule, changing the IP to my gaming machine's IP and the assigned queue to the higher proirized gaming-queue is ignored. The default-, the p2p- and infrequently the ack-queue are the only working queues.

    • Some menu items at the status and diagnostics are disappearing sometimes. Once I tried playing around with the limiter in the traffic shaper but suddenly diagnostics -> limiter wasn't available anymore. I guess even some more menu items disappeared as the list was very short…

    Would be great to get some feedback - especially regarding the second point of the agenda.

    greetz,
    plex


  • Rebel Alliance Developer Netgate

    UDP nat reflection has never worked properly, not sure anyone has been able to track down exactly why.

    The menu options disappearing might only happen if you installed a package that tried to includes its own menu header file improperly (or it used an out-of-date file). The limiters menu option should never go away, even if you don't have limiters enabled it should show up.



  • As I read your comment regarding the disappearing menu items I remembered, that I installed the widescreen-package some time ago. So I restored an older snapshot without that package and this problem was gone.
    Concerning my traffic shaper issues I spent some more time with configuration yesterday. As far as I know I did not changed any options but suddenly it worked. After saving the configuration I tried to get the limiters running to define a minimum bandwith for my p2p-queue but had no success.

    The only remaining issue is up on the nat reflection. As resulting problems can be avoided by connecting the services via lan-ip directly I can live with that but for the final release it would be a nice to have feature…

    Thank you for your reply.

    greetz,
    plex


Locked