Firmware update and packages won't download from pfsense



  • Hey there,

    I ended up upgrading from RC1 to RC3 by downloading on my laptop and then upgrading that way. I was hoping that that would fix the problem I have with System–>Firmware-->Auto Update, I get the following message :

    "Downloading new version information...done
    Unable to check for updates.
    Could not contact pfSense update server http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/.updaters/"

    Also for Packages-->Available Packages I get a message :

    "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    I'm probably doing something very dumb ... the pfsense box is otherwise functioning fine, with internet connectivity to attached clients

    Anybody able to shed any light on this ?

    Kind regards


  • Rebel Alliance Developer Netgate

    Sounds like the box itself either doesn't have working DNS or default gateway. Check your DNS under System > General, and the gateway under System > Routing.



  • Hey thanks for the reply,

    For DNS setting I have "Allow DNS server list to be overridden by DHCP/PPP on WAN", presumably this means that pfsense should use DNS that it has from DHCP on WAN connections ?

    My WAN1, WAN2, WAN3 are currently using DHCP on local networks. So for instance gateway for WAN1 is 192.168.1.1 (a router). WAN2 is 10.42.43.1 (a ubuntu box with internet connection sharing enabled). WAN3 is down !

    I'm currently testing the setup, and will end up with several WAN's one of which will be static and the other two WAN's will be DHCP, probably in private address space.

    I've also unchecked "block private networks in Interfaces for each of the WAN's

    Anything else I can try ?

    Kind regards


  • Rebel Alliance Developer Netgate

    That depends - do any of those actually supply working DNS over that DHCP?

    Is anything in /etc/resolv.conf?

    Might be safer to hardcode DNS, try Google's public DNS (8.8.8.8 / 8.8.4.4)



  • Hey thanks for reply

    the /etc/resolv.conf file contains :

    domain localdomain
    nameserver 192.168.1.1
    nameserver 10.42.43.1

    I'll give the google dns another try, but I think I tried that already :)

    Kind regards



  • Hi there,

    I noticed this message as the system boots :

    arpresolve: can't allocate llinfo for 192.168.1.1

    so I switched the default gateway to WAN2, now I've got internet connectivity from my pfsense box.

    Does anyone know what causes the above message and how to fix ?

    Kind regards


  • Rebel Alliance Developer Netgate

    It means that your WAN is trying to reach 192.168.1.1 on that interface, and it can't reach it because it can't contact it via ARP. Usually that maens that IP is not actually on that interface.

    Perhaps you are using 192.168.1.1 as your LAN IP, and your gateway on WAN is also trying to be 192.168.1.1. If that is the case, one or the other would have to be renumbered to a completely different subnet.


Locked