Missing module - Broadcom BCM4318



  • Hi!
    Its seems there are missing modules.
    How can i install this module and where can i download?

    pfSense 2.0-RC3-nanobsd (i386) on pfsense
    ASUS WL-120 V2 BCM4318 PCI

    siba_bwn0: <broadcom bcm4318="" 802.11b="" g="" wireless="">mem 0xe0080000-0xe0081fff irq 9 at device 12.0 on pci0
    bwn0 on siba_bwn0
    bwn0: WLAN (chipid 0x4318 rev 9) PHY (analog 3 type 2 rev 7) RADIO (manuf 0x17f ver 0x2050 rev 8)
    bwn0: DMA (32 bits)
    bwn0: [FILTER]

    Enter an option: bwn0: need multicast update callback
    bwn_v4_ucode5: could not load firmware image, error 2
    bwn0: the fw file(bwn_v4_ucode5) not found
    bwn-open_v4_ucode5: could not load firmware image, error 2
    bwn0: the fw file(bwn-open_v4_ucode5) not found

    http://www.freebsd.org/cgi/man.cgi?query=bwi&sektion=4&manpath=FreeBSD+8.1-RELEASE</broadcom>



  • Same Problem here.
    i got an BCM4318 MiniPCI Wlan-Card, and i got same errors as you.

    did someone have an soltulion ?



  • @dw:

    Enter an option: bwn0: need multicast update callback
    bwn_v4_ucode5: could not load firmware image, error 2
    bwn0: the fw file(bwn_v4_ucode5) not found
    bwn-open_v4_ucode5: could not load firmware image, error 2
    bwn0: the fw file(bwn-open_v4_ucode5) not found

    This much suggests the bwn driver needs the firmware file bwn_v4_ucode5 loaded but the firmware file is not present on your system.

    The bwn man page says the FreeBSD port ports/net/bwn-firmware-kmod needs to be installed but this doesn't seem to exist as a package so must be built on a FreeBSD system. I'll look into it.



  • Here is the first of two firmware files I built on FreeBSD 8.1. Remove the .png extension from the filename before copying to /boot/kernel on the target system.

    I expect you will need to add

    bwn_v4_ucode_load="YES"

    to /boot/loader.conf.local (create file if it doesn't already exist) to get the firmware loaded and available to the kernel on startup.

    I don't have any Broadcom WiFi devices so can't test this.

    bwn_v4_ucode.ko.png



  • Here is the second of two firmware files I built on FreeBSD 8.1. Remove the .png extension from the filename before copying to /boot/kernel on the target system.

    bwn_v4_lp_ucode.ko.png



  • I get the following:

    bwi0: <broadcom bcm4318="" 802.11b="" g="" wireless="" lan="">at device 14.0 on pci0
    bwi0: [ITHREAD]
    bwi0: BBP: id 0x4318, rev 0x2, pkg 0
    bwi0: MAC: rev 9
    bwi0: PHY: type 2, rev 7, ver 3
    bwi0: RF: manu 0x17f, type 0x2050, rev 8
    bwi0: invalid antenna gain in sprom
    bwi0: WARNING: using obsoleted if_watchdog interface
    ….

    done.
    Configuring WIFI interface...
    bwi0: need multicast update callback
    bwi0: need multicast update callback
    bwi0: need multicast update callback
    bwi0: need multicast update callback
    firmware_register: cannot register image bwi_v3_b0g0bsinitvals2, firmware table full!
    module_register_init: MOD_LOAD (bwi_v3_ucode_fw, 0xc3ad6c80, 0) error 6
    bwi_v3_ucode: firmware image loaded, but did not register
    bwi0: request firmware bwi_v3_ucode failed
    bwi0: bwi_init_statechg: error 12 on MAC init
    bwi_v3_ucode: could not load firmware image, error 17
    bwi0: request firmware bwi_v3_ucode failed
    bwi0: bwi_init_statechg: error 12 on MAC init
    bwi0: need multicast update callback
    bwi_v3_ucode: could not load firmware image, error 17
    bwi0: request firmware bwi_v3_ucode failed
    bwi0: bwi_init_statechg: error 12 on MAC init
    done.

    I found this  /boot/modules/bwi_v3_ucode.ko, looks like the firmware is there

    2.0-RELEASE (i386)
    On a Gateway notebook</broadcom>



  • I have the same issue with a BCM4306

    The firmware cannot be loaded (firmware table is full)
    Seems that this patch should be applied  ….

    http://fxr.watson.org/fxr/ident?im=10;i=FIRMWARE_MAX
    http://lists.freebsd.org/pipermail/svn-src-all/2010-March/021027.html

    Where can I find an How to patch and compile my own kernel for pfsense 2.0 ?

    Not sure those instructions are for a pfsense 2.0 ?  http://devwiki.pfsense.org/DevelopersBootStrapAndDevIso ?

    Thanks in advance
    Etienne


Locked