Configuration XML Encryption Problem



  • So I was going to transfer my config to a new machine and I decided to encrypt the XML file and now PFSense is unable to read it :'(. Do I need to decrypt it before I send it to my gateway? If so, how can I do that.

    I also tried creating a new one from the unconfigured machine using encryption and it still can't read it. Basically I downloaded the encrypted configuration and then promptly tried to restore it. Is there just a problem with the encryption/decryption in PFSense? Any help would be much appreciated.

    Yes I know the password, and yes I type it into the config restore menu.

    The error it gives me is as follows:
    The following input errors were detected:

    You have selected to restore the full configuration but we could not locate a pfsense tag.

    I am running the most recent version of 2.0RC3. The July 4th build.



  • So… can I get someone to at least try the experiment I tried above and see if they get the same problem? Backup the config with encryption then immediately try to reload it. At the very worst, it will work and your box will reboot. Just make sure you backup your RRD data too! I just want to see if it really is pfsense and not just me.



  • BOTH machines are running version 2.0 RC3 ?? or no….



  • Works for me doing exactly as you describe.



  • Wow… that's very interesting. Yes both were on 2.0 RC3. I tried again just now and it still doesn't work. Maybe it's a bad install? Anyway, thanks for the replies.

    I'm going to re-download, re-md5, and re-install, to see if I got a bad install. I can always just reload my config... or can I... O.o

    If it doesn't work, is there a way I can decrypt it outside of pfsense and then send it? Because loading config works just fine as long as it's not encrypted.

    EDIT: After a full reinstall I still have the same problem. I think I'll just start over from scratch (ugh). Thanks for the help.


Log in to reply