Sticky connections with dual wan.



  • I have a setup where I need to use sticky connections but when I enable it I get the famous, kernel: arpresolve: can't allocate llinfo for xxx.xxx.xxx.xxx (My Gateway) in the log file. Here is my setup. I am using 2 alix boards and both are up to date as of the write of this.
    Board one) Master
    Wan) 2 cable modems feeding into the wan on Vlan 10 and 11
    Opt1) 2 cable modems feeding into the opt1 on Vlan 12 and 13
    Lan feeding 10.59.20.xxx

    Board two) Slave
    Wan) 2 cable modems feeding into the wan on Vlan 10 and 11
    Opt1) 2 cable modems feeding into the opt1 on Vlan 12 and 13
    Lan feeding 10.59.20.xxx

    All is working well, ie load balancing, failover, captive portal, DHCP failover, and carp. The only little issue I see with carp is the captive does not copy authuncated users from the Master to the slave. However If I disabel the master and the slave picks up you do not have to reauth.

    The real problem is when I enable sticky connections. I get the infamous kernel: arpresolve: can't allocate llinfo for xxx.xxx.xxx.xxx. I know that the sticky connections work on a single controller because I have a number of them in the field with it enabled and working fine. I now sure if there is some setting I am missing with the carp or what. I have searched all the blogs and havent come up with anything. I know the setup is bazar, but I am quite impressed at how apt PFsense is to handle such a complexed setup. i just goes to show the great work the guys have done with the code. I was hoping one of the latest updates would fix something but it hasn't. Thanks for any help from you guys.



  • Is there no answer for my question? ???



  • What does not work?
    Outboutn load balancing? Inbound?



  • When I enable sticky connections I get the following in my log file. kernel: arpresolve: can't allocate llinfo for xxx.xxx.xxx.xxx. I have sticky connections enabled on other installes and it works but this is the only place I am using carp. The other installs are single boxes.



  • Well this had been up for a week now and still no answer. I just did an update to todays snapshot and still have the same problem. When i enable sticky connections the log gets loaded with kernel: arpresolve: can't allocate llinfo for xxx.xxx.xxx.xxx. The outbound internet slows to a crawl. Does anyone have any suggestions.



  • Bump Any answers??



  • I and several other people on the forum are having the same problem[1]. I think its most likely caused by this bug in the FreeBSD kernel:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=148290&cat=

    I'm running 2.0-RC3 (i386) built on Wed Jul 13 18:38:42 EDT 2011 atm, which still displays the issue described in this FreeBSD bug report.

    [1] http://forum.pfsense.org/index.php?topic=38289 and http://forum.pfsense.org/index.php/topic,33504.0.html



  • I'm affected with this issue as well.

    Can't use sticky connections without all internet outgoing being stopped after one or two minutes.

    My config:

    1x WAN PPPoE
    1x WAN DHCP

    1x LAN DHCP


Log in to reply