[SOLVED] 2.0RC3 crashes on one one type of hardware



  • Hello

    [solved: exelent service and support from appliance shop to make modification to get hardware for 1.x.x to work also with new 2.0. Thanks ti applianceshop and this forum]

    I have four boxes from applianceshop. Two of them keeps crashing. The other two seems not to crash. It might not be statistically significant, but that is how I see it for the moment.

    The ones that crashes are like this one with optons 1.6MHz processor and 2GB RAM
    http://www.applianceshop.eu/index.php/firewalls/opnsense/opnsense-rack/opnsense-ghz-rack-edition-pfsense-appliance.html

    They came original with the 1.2.3, but I did the upgrade to the 2.0 and have been adding new snapshot 2-3 times per week ever since.

    What should I post to get feedback? Right now one has been taken out of production and the other one just crashed during or just after a reboot an hour ago. It is one the latest snapshot as of 6/7-2011. When it comes up I can try to pull whatever data that could be usefull. Please guide and I do my best to provide logs etc.

    BR. Anders



  • Not aware of any issues with their hardware and 2.0, I know they've done testing though not sure to what extent. Stability issues at this point are pretty much guaranteed to be hardware-specific. I emailed my contacts there to find out more.

    If it's a kernel panic you should get a prompt when you log back in after it reboots to submit a crash report. If you submit that, we can tell more about the nature of the problem from what's in that report. We don't get too many of those currently (most all are clearly induced by hardware problems), but I would need your WAN IP to identify which is yours for sure.



  • Hi, we're also using a lot of boxes from them (several models), most of them on 2.0rc3.

    You could try leaving a console cable connected so you can see if something is going on when it crashes. (use an old laptop that can be put next to the pfsense box for a few days?)



  • Back with more info.

    First of all. It will only be an issue for us that previously ordered a GHz boxes with 1.x.x and self did the upgrade to 2.0.

    I emailed applianceshop and they responded with both the solution (yihaa) and a very detailed "walk-through" on how to imlement it.

    Issue is described like this:
    "The most probably reason for the crashes is that the Ghz hardware in combination with pfSense 2.0 needs apic to be 'enabled' and acpi to be 'disabled'."

    Fix is to edit loader.conf.local and add (or edit) these to lines:
    hint.acpi.0.disabled="1"
    hint.apic.0.disabled="0"

    So if anyone got any GHx boxes that were shipped with 1.x.x they now know what is wrong - and that it can be fixed.

    Thanks for info on both the crash report. I will do that if similar future problem arise. Also thanks for tip on serial cable.

    BR. Anders



  • I will just post the full walk through. It was not trivial to me. Maybe others cna make use of it to.

    Only for GHz boxes from Applianceshop ordered with 1.x.x where you self did the upgrade to 2.0! And probably only if they crash every two weeks or so.

    Also when following the guide remember to login with your admin account.

    To check and enable apic or disable acpi please follow these instructions:

    • Login to the pfsense box using ssh or serial console (you can use Putty for both options)

    • Enter 8 to gain access to the console

    • Type mount –rw /

    • Type cd /boot

    • Edit loader.conf.local, type vi loader.conf.local

      • i. Move to the last line and last character using the cursors
      • ii. Now enter a
      • iii. Look for and if necessary insert hint.acpi.0.disabled="1" (you can do this with copy past, select text / ctrl+c and then right mouse click in the vi window)
      • iv. Look for and if necessary insert hint.apic.0.disabled="0"
      • v. Now save and exit by enterin Esc : wq + Enter (sequential)
    • Type mount –w /

    • Type shutdown –h now

      In doubt? I suggest you write to Applianceshop



  • Glad to hear you have a resolution, thanks for following up here.

    Note you want that to be in loader.conf.local not just loader.conf. I edited both of your posts to correct the filename. loader.conf contains the system defaults and is overwritten on upgrades, where loader.conf.local is never changed by anything but you, and what it contains overrides what's in loader.conf. I also followed up with applianceshop to ensure their instructions are updated.

    You can also edit that in Diagnostics>Edit file rather than the command line for those who are more comfortable sticking with the GUI.



  • Super. I will get right on with the editation.
    Thanks for doing the job with updating post and contacting Applianceshop.

    BR. Anders



  • I am back again. I cannot find the loader.conf.local. Is is supposed to be in /boot as the loader.conf or different folder?

    If it should be in /boot - but is not - shall I then just create it and put the to lines of code into it?

    BR. Anders



  • create that by yourselve. /boot is the location



  • Ok. It is done now. I also did an update to latest build. I can confirm that the loader.conf is overwritten. My editations in that file are now gone. The newly created loader.conf.local is still there with the two lines.

    After this modification the one box in production has crashed no more. As of writing there is 5 days of uptime compared to aprox a crash a day before. So hardware for 1.2.3 can easily run the new pfsense 2.0 with this small modification.

    Case is closed. Hardware is running pfsense 2.0.

    BR. Anders


Log in to reply