Unusual message at console [SOLVED]



  • Hi there,

    I Installed today new machine (Cd image downloaded yesterday, and I386) and I noticed somekind of slowliness. At console there is following error:

    Approaching the limit on PV entries, consider increasing either the vm.pmap.shpgperproc or the vm.pmap.pv_entry_max_tunable
    

    And when i went to system tunables there was no either one of these entries, I didn't want create new entry because I dont know what should be the value.

    I'll admit that i haven't updated that machine, but i was wondering that slowliness, and hardware is brand new, today bought from reseller, even the power is brand new.

    Only connection what have connected to this machine was lan and console.
    I halted system for end of day and i'm going to sleep. If i'm lucky i can take system in use tomorrow.. ;)

    BIG THANKS TO: Gloom and WallabyBob



  • You can use sysctl to show the current values and work from there eg.

    sysctl vm.pmap.shpgperproc should return the default value of 200

    Try increasing it to 500, vm.pmap.pv_entry_max should automatically increase as well.

    If you need a brief description of what it is you are changing sysctl -ad | more  will give a 1 liner of each.

    What intrigues me is that I've only ever seen these messages when databases or lots of memory intensive applications are involved.



  • Thank you gloom i'll try your suggestion in minutes.
    I haven't ever seen that kind of error messages before. I'm more like windows sort of guy with little knowledge of linux, but no knowledge at all of bsd based systems

    I forgot to mention that when this information is at console screen webgui is quite slow. some of reasons might be also, that i didn't connect that firewall to wan at all and it tried contact dns and update servers.



  • Okay..

    Now i have something else.. I dont know how to increase this value.. I'll try to search a bit.



  • Okay

    I think i'm out of my league right now.
    Tried to use single user mode to config with```
    /sbin/sysctl -w vm.pmap.shpgperproc="500"

    
    Output was
    

    sysctl: oid 'vm.pmap.shpgperproc' is read only

    
    Now i'm glueless
    
    EDIT:
    Why to do everything hardway.. /boot/loader.conf added line```
    vm.pmap.shpgperproc=500
    ```and booted machine


  • A number of system tunables can be changed only at boot time.

    Edit /boot/loader.conf.local (it doesn't matter if it doesn't exist) and add

    vm.pmap.shpgperproc="500"
    ```save the file and reboot. On completion of startup check the new value has been adopted:
    

    /sbin/sysctl vm.pmap.shpgperproc



  • @Wallabybob:
    Thanks but you were little too late



  • /boot/loader.conf is not guaranteed to survive a firmware upgrade. /boot/loader.conf.local is guaranteed to survive a firmware upgrade.



  • Thank you for info. I already updated to 7th and 8th of june updates today and this setting survived.


Locked