[solved] 3g as wan not coming up after reboot and stays disabled



  • hello!

    i am trying to build a mobile access point with 3g modem as wan. currently i am using a huawei e220 usb connected to an alix 2d13 using pfsense 2.0-rc3 i386 embedded.
    the problem seems to be, that the wan interface is started before the device is recognized:

    ugen0.2: <huawei technologies=""> at usbus0 (disconnected)
    done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configuring QinQ interfaces...done.
    Configuring WAN interface...starting ppp0 link...done.
    Configuring VR0 interface...vr0: link state changed to DOWN
    done.
    Configuring VR2 interface...vr2: link state changed to DOWN
    done.
    Configuring ATH0 interface...stray irq7
    wlan0: changing name to 'ath0_wlan0'
    too many stray irq 7's: not logging anymore
    ugen0.2: <huawei technologies=""> at usbus0
    u3g0: <data interface=""> on usbus0
    u3g0: Found 2 ports.
    umass0: <huawei 0="" 2="" technologies="" huawei="" mobile,="" class="" 0,="" rev="" 1.10="" 0.00,="" addr=""> on
     usbus0
    done.</huawei></data></huawei></huawei>
    

    there were some snapshots some weeks ago where it worked, but they had problems with the dhcp-server and were not able to reboot.

    has anyone so far succeeded in using a 3g modem as wan (or at least tried)?
    hopefully i just missed some configuration option, but if not i'm of course ready to provide some more details!

    regards,
    andy



  • You have disconnected teh USB and then inserted again which is not currently supported during boot at least.

    Leave you device connected since preboot and it should work normally.



  • i never! removed the usb device. it always stays connected.
    but at the time the ppp0 is started there is no such thing as a /dev/cua.0 and after the reboot the dashboard simply displays a red x beside wan.
    then i can click on wan, leave all entries as they are and click save and then apply and wan goes up. rebooting the device leads exactly to the previous state.



  • ugen0.2: <huawei technologies="">at usbus0 (disconnected)</huawei>

    That means either the device is faulty or it is not plugged in well!
    Or some other hw issues.



  • maybe this has something to do with the necessary modeswitching for those devices?
    changing cable and/or port helps nothing. still the modem gets ready far too late for the interface.
    is there a possibility to enter a delay for the wan interface to be started?



  • Not on 2.0 presently.



  • well, this weird behaviour is kind of solved.
    i recently got my hands on another huawei e220 and it worked out of the box. the difference was the firmware. while the slow one was x.116 the working one was x.117. a firmware flash later both work.

    thanks for all the replies!!


Log in to reply