OpenVPN issues..this is just FYI



  • I spent a couple of weeks trying to get the OpenVPN to work with road warriors.  I searched and googled this and that.  Turns out for whatever reason old settings in the config.xml remains after I deleted the OpenVPN.

    So basically I deleted all certs and users that pertains to OpenVPN, deleted the OpenVPN, deleted the firewall rules for it and uninstalled the client export package.  Then went into the config.xml and deleted remnants of the settings.  Then installed the OpenVPN Client export package and used the wizard to set things up.  Once I did that everything worked fine except for revoke cert issue which is an easy fix by creating a dummy cert and then revoke it.

    Yes I searched all over the fourms and no matter what I did it never fixed the problem.  It would have been nice the settings in config.xml actually clear itself after purging the OpenVPN so I can use the defaults.

    Just wanted to pass the info along if you guys are still having issues with it.

    2.0 looks awesome!

    Darkk



  • The problem with parts of OpenVPN, certs etc. remaining I had with a previous installation. Because I could not fix it I did a complete reinstallation.

    The problem with the CRL is discussed here. Please try to help us in this thread:

    http://forum.pfsense.org/index.php/topic,36414.15.html



  • Thanks for the heads up on the CRL issue.  Not sure why OpenVPN couldn't handle a zero byte CRL file as there aren't any revoked certs during a new install.  So yeah creating a revoked cert worked. Also, good to know that I can remove the revoked cert and it'll keep working.  Haven't tried that part yet in the latest snapshot.

    Darkk


Locked