Accessing freenas from different subnet ?



  • I have my freenas server on 192.168.1.250 on my lan interface.

    I am trying to access my share via my Wlan interface which is 192.168.2.1,

    but i cant gain access to my shares.

    Is there a special rule i need to create and can someone shed some light.

    thank you



  • yes, those are two different networks; youll need to add a PASS rule on your WLAN tab to be able to access the specific IP of your freeNAS box.

    source: WLAN subnet (or narrow down to IP of computer your trying to access freenas from; if that PC uses dhcp to aquire its address set a static rule in the pf dhcp server for that device)

    destination: 192.168.1.250

    protocol: tcp udp

    source port: ANY

    dest port: 80 & 443  (set an alias to use multiple ports, dont fill in 80 and then 443 in rules page, that obviously will open a range which is not what you want)

    –- turn logging ON on the pf box to trouble shoot; it may very well work after the above rule is applied; if not and you can see no logs showing an active block, the settings in freeNAS need to be tweaked



  • thanks for suggestion, but it does not work



  • oops; i completely misread what you had written;
    i gave you the ports to access your webUI i dont know what i was thinking…

    what protocol are you using to share files ? is the a samba share ? NFS ?



  • samba



  • so please try allowing the following ports:

    netbios-ns 137/udp # NetBIOS Name Service
    netbios-dgm 138/udp # NetBIOS Datagram Service
    netbios-ssn 139/tcp # NetBIOS Session Service
    microsoft-ds 445/tcp # Microsoft Directory Service



  • You're probably missing a default gateway or have it set wrong on FreeNAS would be my first guess.



  • i have bridged my interfaces to save the hassle.

    I might try your suggestion in my next snapshot test.



  • @cmb:

    You're probably missing a default gateway or have it set wrong on FreeNAS would be my first guess.

    ive been told that it wont work because i need a win server apparently.

    samba does not allow shares to different subnets ?



  • only fix atm i have found is to bridge wlan and lan , therefore allowing nas and wifi on same subnet in order for me to access my share.

    ideally i dont want to do this though and would like to keep my interfaces separate.



  • I assume you're talking about accessing the share via "my network places".
    If you access the share via it's IP directly is should work.

    start –> run --> \IP_of_share



  • @GruensFroeschli:

    I assume you're talking about accessing the share via "my network places".
    If you access the share via it's IP directly is should work.

    start –> run --> \IP_of_share

    yes and also by mapping network drive.

    I definitely think its a problem with the subnet though.

    because the nas is on 192.168.1.0/24 and my wifi is on 192.168.2.0/24

    therefore i assume wifi is not allowed to access the nas.

    no matter what rules i create it doesn't work.

    I will try ericab suggestion regarding opening them ports. but for now the bridging seems the only solution to work for me.



  • I think samba and windows are picky about file shares.  Might be easier to create a rule on the WLAN to allow traffic from the NAS to your LAN so it can broadcast itself to your LAN network.  You can easily do that adding your FreeNAS as the Source and protocol to ANY and rest by defaults.  This way rest of the hosts on the WLAN won't have access to your LAN.

    Darkk



  • has anyone actually have a similar scenario?

    because these suggestion do not actually work.

    I would appreciate someone print screen shot their rules and posting them for me to have a example to follow.



  • Yes i run the same setup and it works just fine.

    My firewall rule for the WLAN:




  • It would be helpful if you were much more specific in your reports than "does not work". For example, complete the sentence I did … and I saw ... but I expected to see ... and give the exact text of any report from the computer.

    When you changed firewall rules did you Reset states afterwards? In the web gui, go to Diagnostics -> States, click on the Reset States tab for an explanation.

    I don't have your configuration but I do have a Linux system on an OPTx network and it routinely accesses Windows shares on my LAN network in order to back them up. The access is allowed for the firewall on the OPTx interface: PASS PROTO=IPv4*, Source=, Port=, Destination=, Port=, Gateway=*, Queue=None, Schedule= <blank>I suggest you start with a similarly open rule and get that working then gradually tighten it (remember to reset firewall states) to your requirements by changing one rule parameter at a time.</blank>



  • thank you i will try this on the new snapshot when i get a chance.



  • i fixed it guys.

    tried the new snapshot and its working now with the rule activated on lan

    however i had to insert the ip via //ip/share etc

    because it doesnt seems to auto discovery when click network which is no problem


Locked