[SOLVED] PFsense not managing traffic properly



  • After doing some more diagnostics I've narrowed down the cause of my problems in this thread, http://forum.pfsense.org/index.php/topic,38786.0.html to a glitch in the 2.0-RC3 firmware. This glitch saturates the network connection whenever there's any kind of sustained network traffic such as downloading going on. The really strange part is that the network saturation seems to be totally self contained within the router, in the sense that the traffic graphs report that my IP is downloading at full speed, but my actual download speed according to the status bar is going at about a tenth of my top speed.
    Any ideas on what could be causing this issue?

    EDIT: Problem solved. I'm not sure what was causing the issue, but a full reinstall of the latest snapshot fixed the issue



  • Sounds like you are simply seeing traffic according to the router in bits per second, and your browser or whatever software is reporting the speed in bytes per second.  If you have a "500k" (bits per sec) download internet service, you can expect to download files max 50k (bytes per sec).

    Sorry to mention this if you already know about that.



  • I am familiar with the concept. However that isn't what's happening here. During my testing, I was the only one connected to the router, as such I should have been downloading files at the maximum speed my line will allow. However this didn't happen while my pfsense router was managing the connection. As mentioned earlier, while the traffic graph reported that I was downloading at full speed, the actual download speed as reported by the statusbar was less than a tenth of that. Also, my connection was saturated to the point where only text based sites would load properly, anything remotely bandwidth intensive (flash based sites etc) would time out. It was only when I switched out my pfsense router for a backup system that I had laying around that the situation resolved itself and speeds went back to normal.



  • Are there any ideas as to what could cause this kind of problem? I would like to resolve this asap as my current backup solution does not support MLPPP, which is something that I was taking advantage of before.



  • bad network card ?



  • It would be useful to have more information about what is happening. A packet capture on the WAN interface and running pftop on the pfSense console or a SSH session should give more information about the apparent superfluous traffic. pftop displays summary information of firewall states. Typing h to pftop displays a help page including options to sort the display. Sorting on bytes or packets should show the busiest connections.


Log in to reply