Vlan's Setup for Pfsense 2.0 RC3



  • I'm a new'b to Vlans & Pfsense, i've been using Untangle for the last 1.5 years and like it, however it doesn't support vlans, so i have setup another "PLAY" network at home with a managed switch and a pfsense router running Pfsense 2.0 RC3.

    Id like to know if there is a step for step guide for setting up vlans for NEWBS from start to Finnish.

    If not, I could post what i'm trying to accomplish and go step for step ?

    Meow.



  • Any help ?



  • INTERFACES - ASSIGN - VLANs
    There you can create all your VLANs.

    After this go to:
    INTERFACES - ASSIGN - Interface Assignment
    There you have to assign your VLANs.

    No you do the same as with every other interface, activate, IP, DHCP server, Firewall rules and so on.

    Remember:
    The parent interface, for example igb0 is always UNTAGGED. Every interface you created with a VLAN is always TAGGED. You need to know this if you will connect this to your switch.



  • @Nachtfalke:

    INTERFACES - ASSIGN - VLANs
    There you can create all your VLANs.

    After this go to:
    INTERFACES - ASSIGN - Interface Assignment
    There you have to assign your VLANs.

    No you do the same as with every other interface, activate, IP, DHCP server, Firewall rules and so on.

    Remember:
    The parent interface, for example igb0 is always UNTAGGED. Every interface you created with a VLAN is always TAGGED. You need to know this if you will connect this to your switch.

    I used port 1 on my 24 port gigabit switch as the main IN from pfsense…

    So..

    Do you mean that when you, create each vlan, port one on each vlan should be tagged ( in simple terms tagging port 1 ) is for traffic to be routed around in each vlan from that port 1 ?



  • I think you are right. Not sure if I understand you correct ;)

    On the switch you have to configure a port, oftn known as "TRUNK" port which handels all VLANs you created on pfsense. And this TRUNK port must be in TAGGED mode.

    pfsense-NIC (TAGGED) –---------(TAGGED and TRUNK with ALL VLANs) port 1 on switch-----(all other ports are UNtagged and belong to only one vlan)----connect clients



  • I think ill be re-installing pfsense tomorrow rc3 V2.0 and starting all over, wish there was a step for step guid to get this working.

    I did manage to setup one of my Cisco / linksy RVS4000's lastnight and got all my vlan's working perfectly so i know my switch is setup properly at least.


Log in to reply