Squid / Squid3 issues and streaming



  • About 1 month ago I decided to have a go at Squid, squidguard, and HAVP.  I installed all these and had everything working flawlessly (or so I thought). The only issue I later found was that some streaming sites became very slow or slow to start.  YouTube videos now take a while to start.  I radio station I listen to doesn't start playing for 13min, and is 13min delayed once it starts.  If I set my IP to not be proxy-ed in squid, everything works perfectly, so I know it is squid (or squidguard or havp).  I did some reading, but couldn't find any simple fix.  One thing I read was that one guy tried squid3 and everything then worked.  So I figured I'd try squid3.  Tried the install, it failed, and it took down my system.  I had to restore to factory defaults to get back in.  Then restore an old backed up config (pre squid).  So now I have a fairly clean system, and I figured I'd try squid 3 again (without squid 2 already installed).  Unfortunately, the install still fails, error:

    Checking for package installation…
    Downloading http://files.pfsense.org/packages/8/All/squid-3.1.14.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/squid-3.1.14.tbz.
    of squid-3.1.14 failed!

    Installation aborted.Backing up libraries...

    So, does anyone know how to fix the streaming issues with squid2?  Or how can I install/try Squid 3?

    I'm running the July 11 nightly, btw, on i386.

    Thanks.



  • Hi,

    squid3 isn't really stable at the moment. There ar missing dependencies and so on. To have a stable system you'll have to use squid2.

    I am using squid, too but without problems in youtube or other streamings. Did you enter any custom options like caching windows updates and so on ?

    In PROXY SERVER - CACHE MGMNT
    you can enter all the domains you do not wish that they are cached e.g.
    youtube.com
    radio.com

    Than these domains will not be cached but everything else. But I think there is something else in your config which causes this problem.



  • Thats not true!

    You have to exclude the domains in havp, squid is NOT the culprit.



  • @_igor_:

    Thats not true!

    You have to exclude the domains in havp, squid is NOT the culprit.

    You are right - I missed that avp is using HAVP.
    I don't know how to configure that in HAVP.



  • I will re-install Squid and SquidGuard and see if my problem still exists.  Then I will add HAVP.  I will let you know what I find out.

    Thanks



  • You guys were right.  I reinstalled everything, Squid, SquidGuard.  All was fine.  Added HAVP, YouTube got slow.

    Added:

    ytimg.com/
    youtube.com/
    googlevideo.com/

    to the HAVP whitelist and all appears to be well now.

    Thanks.


Log in to reply