Crash Report - Parse Error



  • Upgraded from the July 7th amd64 snap to the July 13th amd64 and I'm getting a crash report or programming bug at every bootup.  System Logs look fine but through the monitor I see the following error right before bootup is complete

    Parse error: syntax error, unexpected T_STRING in /etc/inc/pkg-utils.inc on line 550

    Seems to still be running fine in spite of error.  Any thoughts?

    Update: Related to package installation yet I dont have any packages installed on this box.  Going to System/Packages in the Web GUI gives the same error as above.



  • You must be on the IPv6 branch? I just fixed that but it wasn't a problem in 2.0, only what's now the 2.1 branch (with IPv6 and gettext).



  • @cmb:

    You must be on the IPv6 branch?

    No?

    Using the Auto Update URL

    http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_RELENG_2_0/.updaters/

    and the master branch Git

    git://github.com/bsdperimeter/pfsense.git



  • Ok, guess I got caught up in early adoption.  Thought it was just a regular 2.0 RC/HEAD update.

    Getting this now btw after committing your change.

    Warning: Unexpected character in input: '' (ASCII=92) state=1 in /etc/inc/pkg-utils.inc on line 556 Parse error: syntax error, unexpected '"' in /etc/inc/pkg-utils.inc on line 556



  • Reinstalled RC2 from scratch, restored config and upgraded to latest release but this time I disabled Gitsync Auto sync on update, all is well now.



  • Oh if you're set to gitsync to mainline after upgrade, mainline is now 2.1 so you don't want that, 2.0 is RELENG_2_0.


Log in to reply