Snort SQL Error in new version 2.9.0.5 pkg v. 2.0 and Pfsense RC3



  • Hello,

    We installed the latest version of PFSense, the 2.0-RC3 (i386) built on Tue Jul 12 9:45:04 p.m. EDT 2011 and the version of Snort 2.9.0.5 pkg v. 2.0.

    We know it is under developement but we have database errors when we go on the tab Update.

    Warning: sqlite_query(): no such table: SnortDownloads in /usr/local/pkg/snort/snort_download_rules.inc on line 72
    Warning: sqlite_fetch_array() expects parameter 1 to be resource, boolean given in /usr/local/pkg/snort/snort_download_rules.inc on line 78
    Warning: sqlite_query(): no such table: SnortDownloads in /usr/local/pkg/snort/snort_download_rules.inc on line 72
    Warning: sqlite_fetch_array() expects parameter 1 to be resource, boolean given in /usr/local/pkg/snort/snort_download_rules.inc on line 78
    Warning: sqlite_query(): no such table: SnortDownloads in /usr/local/pkg/snort/snort_download_rules.inc on line 72
    Warning: sqlite_fetch_array() expects parameter 1 to be resource, boolean given in /usr/local/pkg/snort/snort_download_rules.inc on line 78

    Nothing works.

    The old version worked but no longer in the package.

    Installation is clean and new, we just restore the data off package.

    Does anyone have an idea.

    Regards

    JNL



  • Nobody help me or idea :)
    jnl



  • Based on watching the forums for a while and experimenting with snort a few times (but not recently), my recommendation is to not use Snort with pfSense version 2.0 until the final 2.0 is released and Snort is updated to be compatible. Snort is not very actively developed/updated to continue working with the dev snapshots and errors return all the time.



  • @Jeannoel:

    Nobody help me or idea :)
    jnl

    search the forum, the answer was giving about a week ago… since the old and new snort can't live together within the package system, the maintainer is waiting for the dev team to help with the binaries so the new snort package can be finish.. Since the pfsense dev team is working hard to release 2.0, I would think that takes priority over the snort package


  • Rebel Alliance Developer Netgate

    @Cino:

    search the forum, the answer was giving about a week ago… since the old and new snort can't live together within the package system, the maintainer is waiting for the dev team to help with the binaries so the new snort package can be finish.. Since the pfsense dev team is working hard to release 2.0, I would think that takes priority over the snort package

    The maintainer of the snort package is not one of the developers working on pfSense in general, so that isn't a factor. Many of us are hard at work trying to get 2.0 ready, but that doesn't have anything to do with the current state of the snort package.



  • @jimp:

    @Cino:

    search the forum, the answer was giving about a week ago… since the old and new snort can't live together within the package system, the maintainer is waiting for the dev team to help with the binaries so the new snort package can be finish.. Since the pfsense dev team is working hard to release 2.0, I would think that takes priority over the snort package

    The maintainer of the snort package is not one of the developers working on pfSense in general, so that isn't a factor. Many of us are hard at work trying to get 2.0 ready, but that doesn't have anything to do with the current state of the snort package.

    I understand that the maintainer isn't one of the pfsense developers but the snort maintainer stated he was waiting for help with the new snort binaries. That they are compiling with errors.
    see this post:
    http://forum.pfsense.org/index.php/topic,37557.msg199104.html#msg199104


  • Rebel Alliance Developer Netgate

    You assumed that the project mentioned is 2.0. It is not.


Log in to reply