Upgrad to 2.0 failed…



  • Hi guy

    i upgraded 30min ago from 1.2.x (sorry don't remember) to 2.0 from the Web-GUI.
    The installer downloaded the new firmware and begann to install the new release with the messages like "upgrading pfsense will reboot automatically…"

    now my fw never rebootet and the Web-GUI isn't working anymore but my internet-connection is still up and running.

    if i connect to the Web-GUI i receive only this output:

    Parse error: syntax error, unexpected '&', expecting T_VARIABLE or '$' in /etc/inc/interfaces.inc on line 1093 
    

    any suggestion or idea?

    thx



  • I hope you have a backup of your configuration.
    Make first to reinstall everything and load the backup of your configuration.



  • I just got a similar problem upgrading the 7/8/2011 snapshot to the 7/14/2011 snapshot. Bug in today's and yesterday's snapshot maybe? http://forum.pfsense.org/index.php/topic,38936.0.html

    Regardless though, if you have console access you might be able to "upgrade" from the console to an older snapshot (mirrors have a 6/28/2011 file IIRC). I've never done it that way so I don't know if you can even do that. If that doesn't work your only option is reinstalling 1.2.3 or a fresh install of 2.0 from the 6/28/2011 snapshot and reconfigure everything. Going to 2.0 would be best, you can save your config and if something like this happens again just restore the config after getting back to a working system. Or you could just stay with 1.2.3 until 2.0 is finished (seems like it will be VERY soon honestly).



  • @Ma.S.Caos.-:

    I hope you have a backup of your configuration.
    Make first to reinstall everything and load the backup of your configuration.

    yes sir! :-)
    do you know if i can install directly install 2.0 and use the backup of the previous version to restore my config?



  • thank you guys!
    i will reinstall my fw next weekend!
    the strange thing is only that my network is still working  ;)



  • Nope I do not believe you can restore an old config into 2.0. You definately can't restore a 2.0 config to 1.x. For what it's worth, mine was caused by a goof on my part. I didn't see that the IPv6 branch had been changed and I needed to fix a URL during the update process. Jimp helped me correct that though and my firewall is working just fine on the latest snapshot. And yeah mine was otherwise working just fine but the WebGUI was dead.



  • You can restore any older config to any newer version.

    If you upgraded 1.2.x to 2.0 amd64 it won't reboot on its own, cross-architecture upgrades aren't supported.



  • ok, thank you guys again!
    will try to install latet RC and restore my config and tell you hows gone  :-\


Log in to reply