Botched upgrade from 7/8 snap to 7/14 snap



  • Upgraded my RC3 build from 7/8 to the latest 7/14 snap and it failed. I am gitsyncing IPv6 into it, maybe that had something to do with it? I'm running it inside ESXi 4.1. Here's what I've got.

    The console now says "pfSense 2.1-DEVELOPMENT-pfSense (i386)". Did the updater connect to the wrong source or something? I did the change in the sticky after 7/4 when it told me for a few days I was on the latest version which is how I got to 7/8.

    WebGUI says the following: "Warning: Unexpected character in input: '' (ASCII=92) state=1 in /etc/inc/pkg-utils.inc on line 556 Parse error: syntax error, unexpected '"' in /etc/inc/pkg-utils.inc on line 556"

    Console says that line along with a few other lines. Only one other line remains visible once it boots, the others go by too fast. "Warning: Unexpected character in input: '' (ASCII=92) state=1 in /etc/inc/pkg-utils.inc on line 556"

    Basically they appear to refer to the same error. I see in the Install and Upgrades forum someone ran across a similar error (interfaces.inc was the file in question that time) with yesterday's snapshot. It's possible mine is complaining about the same file and it's only being shown on the console during boot and I can't see it.


  • Rebel Alliance Developer Netgate

    You're using the IPV6 branch perhaps?



  • Yep sure am, is that why it says 2.1 devel? I know IPv6 is on the horizon for 2.1 but it used to just say "2.0-IPv6" or something to that effect. Can I take an upgrade file from an older snapshot and use the console to "upgrade" and restore this or will I have to wipe it and start over? Or should I just wait for the next snap and upgrade to that if it fixes the problem?


  • Rebel Alliance Developer Netgate

    IPv6 Code was merged into mainline after 2.0 was branched. If you are using the IPv6 code, you are now using what will be the 2.1 codebase, overlaid on top of the 2.0 binaries. It's not a big deal at the moment, really just a naming difference.

    When 2.0 is released, the snapshots will go back to being built off mainline and IPv6 will be in the base system for 2.1 so it doesn't require the extra gitsync settings.



  • Any idea what caused this? Was it the IPv6 code or something else?


  • Rebel Alliance Developer Netgate

    As I said: Nothing was botched. You are seeing exactly what you are supposed to be seeing when you are using the IPv6 code now.



  • That's true for the 2.1 statement in the console but are you saying the IPv6 code should be causing those errors to show up in the console and in place of the WebGUI too?


  • Rebel Alliance Developer Netgate

    If you aren't actually on the current code, yes. See the post I linked earlier, you need to fix your gitsync url.



  • Doh, I just saw that in the IPv6 forum too. Thanks :)


  • Rebel Alliance Developer Netgate

    I resynced the old ipv6 tree just now so it would pick up the same set of bug fixes the main branch received for that, but that won't be happening quite so often now that it's in mainline. Fixing the gitsync URL is best.



  • Since I can't get into the webGUI I re-ran the gitsync from the console developer shell like you would for the initial gitsync to IPv6 (but used the new URL), doesn't seem to have fixed it. Still get the errors on startup and still can't get into the webGUI. I'll probably reinstall it tonight unless you see something I did wrong?


  • Rebel Alliance Developer Netgate

    A gitsync (to either URL) should have fixed that particular error.



  • That was my thought as well. So since 2.0 has been branched into a mainline now, does that mean release is within grasp?


  • Rebel Alliance Developer Netgate

    Actually try one more sync. I thought you hit one that had already been fixed, but it was a different one.



  • Sweet that fixed it. The console ran through a LOT more text this reboot, most of it about reinstalling packages (VMTools is all I have installed). Everything looks good now, thanks for the help.


Log in to reply