Changes to Squid Configurator



  • Incorrect behavior of the configurator creates a list noaut (Subnets that don't need authentication) wrong.

    From comment "Enter each subnet or IP address on a new line (in CIDR format, e.g.: 10.5.0.0/16, 192.168.1.50/32) that should not be asked for authentication to access the proxy."
    squid.inc generated squid.conf

    acl noauth src  subnet/mask
    subnet/mask
    subnet/mask
    ......

    Need to work
    acl noauth src  subnet/mask subnet/mask subnet/mask …

    Please fill in the source package chenge squid.inc

    
    .....
    else {
    //		$noauth = implode(' ', explode("\n", base64_decode($settings['no_auth_hosts'])));
    //		if (!empty($noauth)) {
    //			$conf .= "acl noauth src $noauth\n";
    //			$valid_acls[] = 'noauth';
    
    // Corrector
    		$noauth = explode("\n", base64_decode($settings['no_auth_hosts']));
    		$noauthed = "";
    		foreach ($noauth as $subnet) {
    			if(!empty($subnet)) {
    				$subnet = trim($subnet);
    				$noauthed .= "$subnet ";
    			}
    			}
    
    		if (!empty($noauthed)) {
    			$conf .= "acl noauth src $noauthed\n";
    			$valid_acls[] = 'noauth';
    		}
    // EndCorrector
    		}
    .....
    
    

    Note a very important work at least for me since that moment gave me a lot of inconvenience since the version 1.2.3 and version 2.0 is preserved.


Log in to reply