How to change boot options?



  • Hi There,
      Im having an issue with Pfsense 1.0.1.  If I let it boot using the default boot settings (option 1) it crashes.

    If I select Enable acpi (option 2) it boots and runs fine.  I have found all sorts of articles on how to boot with acpi disabled but nothing on changing the default boot option.

    Any Ideas?

    P.S.  as you can probably guess my experience with freebsd is nonexistant  :)

    Thanks

    Knotty





  • Thanks Hoba, Checked those out but it only tells me how to boot with acpi turned off :(

    I need to make sure it is turned on.

    I tried following thos instructions except using the set hint.acpi.0.disabled=0 but it still uses option 1 on the boot menu and crashed when initialising the network card.

    Any other ideas?

    Thanks



  • Make sure you make the settings persistent by editing /boot/loader.conf like described in the wiki article. I have to use a similiar setting on my 1U IBM server to disable dmamode for the cdrom or it will stop booting up when detecting the cdrom. Works fine here.



  • Thanks Again hoba,
      But still no go :(

    My Loader.conf looks like this :-
    autoboot_delay="10"
    hint.acpi.0.disabled=0

    But when boot the Box using option 1,  It crashes with a general protection fault when load the network card drivers.  If I use option 2 it boots fine.  I'm just concerned that if the power goes down,  the box will not start unless there is someone here to select option 2 :)

    Thanks for your help

    Knotty


Log in to reply