Traffic shaper holding rates, not shaping



  • Just recently I started messing with the traffic shaper because I was tired of killing my usenet client to watch netflix. I have read a lot of posts, how to's, and such over the past week and I still can't get it right (or maybe I just can't find the right post). So, this is what's happening (pfSense 1.2.3 on a 3Mb Down/768Kb down):

    I set up the wizard, the only things I changed was raising the ack percentage and realtime (higher than what one of the sticky posts recommends but not by much), I changed the NNTP rules to use port 563 and changed them to qOthersDownL  and qOthersUpL, lastly I added rules based on the wizards BitTorrent rules but changed the port range to what my client uses (now there are BitTorrent rules for ports 6881-6999 and 50000-60000).

    After that I applied the settings, reset the states, and everything went fine for a while, usenet took up most of the bandwidth and torrents dropped to the minimum. I watched the queues then started messing with the connections to test things out. I killed the usenet client and my torrents went up to 1Mb (max set by the client), I opened the usenet client back up and it went up to 2Mb but the torrents remained at 1Mb. I waited about 10 minutes then set my torrent client to the upper limit (2Mb), it almost instantly went up and usenet went down. I went through all the rules and queues to make sure I didn't accidentally change something else, didn't see anything wrong. Tried to download an Ubuntu iso, it said it would take 4 hrs. (should only take about 40-50 minutes). I tried resetting all states then everything fell into place, the http download went up , usenet and torrents fell. killed the http download, usenet went up. Killed usenet, torrent went up. Then I reversed it and all the connections held their speed.

    After repeating this several times it seems the only way to get the traffic shaping to work is to reset the states. So when my usenet finishes, I can't get full speed again unless I kill the connections. Same thing on http downloads (which Netflix runs on).

    Can anyone help me out, I will happily give more information if needed.



  • Not quite sure I understand what you are saying is happening but my suggestion would be to watch the queues and see if you can see what is happening, that is, making sure the traffic is going in the right queues.  Not sure what tools are available for 1.2.3, but there should be a pfTop on the console menu, you can start that and hit key '8' to show the queues… also ? to show some help.  Also you might get more help with pfsense 2.0 lately, not sure.



  • Well it took a while but I got it. I think I was getting mixed up, so, I put all the settings in a spread sheet. So, now netflix from my Wii is now uninterrupted, although it is a little slow on the initial load but I'm not concerned with waiting an extra 10-15 seconds until the shaper regulates itself.


Log in to reply