Snapshots, no internet



  • I have used Pfsense 10.01 and snapshots from January with no major problems.
    Upgraded to snapshots from February and lost internet, I have not been able to get it working. Have tried fresh installs with the same result.
    I now have a 1.0.1-snapshot-02-21-2007 running from cdrom. My pc is given an IP-adress, The Pfsense gets an IP-adress from my ADSL modem (10.0.0.x), the web-interface works, I have access to the ADSL modems web-interface and it tests the internet connection as OK. Just the same, no webpages or downloads as it all times out. The outside world is seen, as can be seen when I atemt to update my Linux:

    –06:44:52--  ftp://ftp-linux.cc.gatech.edu/pub/linux/distributions/archlinux/current/os/i686/current.db.tar.gz
      (try:12) => `current.db.tar.gz.part'
    Connecting to ftp-linux.cc.gatech.edu|128.61.111.9|:21... connected.
    Logging in as anonymous ...
    Error in server response, closing control connection.
    Retrying.

    As I currently am booting and running from cdrom, the settings are stock. I have tried to disable the firewall to no avail. The is no errors reported in system-logs, and everything looks just like the earlier working versions. There is no error or warnings during boot.

    I am lost.    HELP.



  • Does it work when not using dhcp at WAN but static? We are debugging some dhclient issues atm, so dhcp at WAN might have issues with some configs lately.



  • Hello:

    May be as the problem I had?

    See this thread:
    http://forum.pfsense.org/index.php/topic,3755.0.html

    Best regards.

    Luis Tark



  • You said you already tried a fresh install so I doubt it.



  • Thanks for answers so far, but there is no solution for me yet.
    I have done a bit more testing, so here we go.

    I have a AMD Duron 800 Mhz processor and 500M ram, 2 cheap nix, a CDrom drive. I have disconnected the HD to ensure that no old config-files can mix into the pot.
    I put a January snapshot in the drive and booted. Answered no to vlan, lan and wan auto. (Lan=xl0, Wan=xl1). When the booting was complete internet was working like a dream, no settings were done at all, so no firewall rules were loaded.

    I the rebooted with the latest snapshot, the same procedure, no diffrenses were observed. However, when the booting was complete, I could access the Pfsense web config, I could access the ADSL-modems web-config so the lan and wan is up running.
    But to get a outside web-page, no go. Firefox informs me that the server at address x can not be found. As can de seen in my first post, a FTP session from terminal does connect to the server and tries to log in, but I then get an "error in server response".
    I have compared the system log from the 2 tests, they are duplicates. If I do a "ifconfig on my linux box, the response is a duplicate.
    I the went to the settings and disabled the firewall, no change. I can not find any difference in any of the settings/info on the Pfsense box.

    I am even more lost. ;D



  • Sounds like a DNS Issue maybe? If you can reach the modem you can pass through pfsense.


Log in to reply