No Internet With WAN connection



  • This is my Very First Setup with PFsense and So Far I really love the software.
    But that Being said I am having Issues with one of my WAN connections.

    The setup I'm trying to achieve is This.

    High Speed cable modem as Primary WAN
    T1 Line as Failover
    Lan with about 20 users

    I tried for 4 Hours yesterday to get internet thru PFsense with the cable modem and Had no Luck.
    As Soon as I switched to the T1 Line everything was VERY simple and setup with no Issues.
    I believe PFsense and the Cable modem have some kind of conflict that not allowing computers to connect to the internet.
    If anyone might have any Suggestions on hat I might try I to resolve this issue that would be Great. Let me know what info you need and I will post it.
    Its The re0 interface that I cannont make work.



  • Sometimes you just have to reboot your modem to get it work, have you done that?



  • Yeah Tried that a Few Times And no Luck.

    If I bypass Pfsense and go right to the Hub All the Computers Can connect perfectly.



  • Your default route goes through your cable modem? (What is the output from the pfSense shell command # netstat -n -r ?)



  • Maybe it has something todo with wan-rule "Block private networks"
    But smarter ones has to answer



  • I'm very Stupid when it Come to this. I'm not even entirely sure the proper way execute the Shell command # netstat -n -r



  • @Metu69salemi:

    Maybe it has something todo with wan-rule "Block private networks"

    That's a good thought. The interface counters show no blacked packets and no pass packets so things haven't got far enough along for this particular wan rule to become an issue.

    For clarity, in this configuration Block private networks should be DISABLED (not ticked) on all interfaces.



  • @IVIilkman:

    I'm not even entirely sure the proper way execute the Shell command # netstat -n -r

    Some options:

    • On pfSense console menu select option 8 (Shell) and type netstat -n -r at the shell prompt (#)

    • On another system ssh with login as admin to the pfSense LAN interface address, at the menu select option 8 (Shell) and type netstat -n -r at the shell prompt (#)

    • From the pfSense web GUI select Diagnostics -> Command prompt and type netstat -n -r in the Command box and click the Execute button.

      With the last option it is pretty easy to copy and paste the command output into a reply to this thread.



  • ok results of the netstat -n -r

    The Top on is the one that Work. The lower Photo Does not Work.

    ![Capture 33.JPG](/public/imported_attachments/1/Capture 33.JPG)
    ![Capture 33.JPG_thumb](/public/imported_attachments/1/Capture 33.JPG_thumb)
    ![Capture 2.JPG](/public/imported_attachments/1/Capture 2.JPG)
    ![Capture 2.JPG_thumb](/public/imported_attachments/1/Capture 2.JPG_thumb)



  • Sorry I didn't spot this earlier. You have an invalid configuration: em1 and re0 belong to the same subnet. You should change em1 IP address to be (say) 192.168.99.1/24 to be distinct from em0 and re0.

    If you have DHCP enabled on em1 you will also need to change the range of DHCP addresses.

    If you have a fair bit of stuff configured around a LAN subnet of 192.168.0.0/24 then it may be easier to change the cable modem's configured DHCP subnet to (say) 192.168.99.0/24



  • Might have to clone the mac of the computer that can connect without issue.



  • Thank you wallabybob Changed the Cable modems DHCP subnet and it all works like a Champ.

    Thanks


Log in to reply