[SOLVED] buggy start of freeRADIUS after pfsense reboot or snapshot update



  • Hi,

    I noticed some problems with the freeRADIUS package after a reboot or an update.
    freeRADIUS is running but it isn't working. No requests from the switch are accepted.
    A restart or first stop the start in the webGUI doesn't work.

    If first have to go to the console, and use:

    kill -9 
    

    Then I can start the freeRADIUS service using the webGUI and then it is working.

    I am running cron, squid, squidguard and freeRADIUS on this machine.

    The stop script in /usr/local/pkg/freeradius.inc just uses "killall radiusd -s".
    Perhaps it would be better to use something like this:

    'kill -9 ps auxw | grep "[r]adiusd -s" | awk '{print $2}' '
    

    I just copied this out of some other scripts and as far as I know this focuses directly on the PID.

    Or is there a possibility to create a cron job which kills radiusd after a certain time after reboot and then restarts it ?

    I do not know, where the problem exactly is located so this are only suggestions with the hope someone else can help to fix this/my problem.

    Thanks in advance!



  • Hi,

    today after upgrading to actual snapshot I had the problem above again.
    freeRADIUS is using nearly 100% CPU usage and I cannot stop/restart it using the pfsense webGUI. I first have to log in via ssh and the kill the process with

    kill -9 
    

    Perhaps someone can add the code from my post above to better stop the radius process.

    Further I think it would be the best way to prevent the 100% CPU usage of freeRADIUS if the service will be restarted again after installation of the package.

    I would really appreciate if someone could fix this or add this code into the package because my programming skills aren't good enough and at least I do not know how and where to submit a change to this package code.

    Thanks in advance!



  • Hi,

    I tested with several different snapshots, latest one is this one:
    2.0-RC3 (amd64) built on Mon Aug 8 18:38:15 EDT 2011

    freeRADIUS is still using 100% of CPU usage after restart of pfsense or after updating pfsense to a newer snapshot. The only possibility I found is to kill the process from the shell and then restart it using the webGUI.

    It would be really nice if someone could help me in this case.

    Or is it possible to put in a script that is waiting for some time after restart of pfsense, then searching the PID, killing it and then restarting freeRADIUS again ?

    Or put this in the freeRADIUS startup script ?

    I am feeling like I am the only one who is using this package because noone else hast this problem ;)

    Thanks


  • Rebel Alliance Developer Netgate

    It's not just you - http://forum.pfsense.org/index.php/topic,38267.0.html

    I tried to reproduce it once upon a time but got side tracked by work and haven't gotten back to it yet. There were many more pressing matters at hand.

    Unless someone submits a fix in the form of a patch or funds the work, it'll just have to wait until someone with the know how to fix it has time to reproduce and resolve it.



  • Hmm…that sound not really good. I hoped that someone could make a dirty hack and kill the radiusd process some time after start and then just restart it.

    But I know that this is a problem of an unmaintained package :(

    ---edit----

    Newer freeRADIUS package version solved this problem.


Locked