In Load Balancing HTTPS site is not working



  • Hi ,

    I am the new member of the forum. I set load balancing in Pfsense . But the issue is HTTPS site is not working properly.Logging out automatically very frequently.

    I am using  Version 1.2.2 .

    any resolution? really urgent.



  • https traffic doesn't like loadbalance, so you need to create rule to use only one gateway at a time or use sticky connections



  • Hi Thanks for reply .

    I have setup sticky connection but connection became stuck in Round-Robin system.Webpages are not opening propely.So I setup Rule in LAN and used Load Balancing behaviour in Load Balancer. As per Pfsense document ,But it is still not working.
    Below is my setup,Please check once and let me know if I missed something else.

    Parameter                  Value
    Action                        Pass
    Disabled                      unchecked
    Interface                    LAN
    Protocol                      TCP
    Source:                      not unchecked
    Source: type                LAN subnet
    Source OS                  Any
    Destination:(not)          unchecked
    Destination:type          any
    Destination port range    HTTPS
    Log checked initially      uncheck
    Gateway                      WAN1
    Description                  Route https through one working connection

    Thanks



  • You can't load balance HTTPS, there is no way around that.



  • by your description it seems to be ok, have you resetted your states after adding this rule above your multiwan rule?


  • Netgate Administrator

    Hi,
    Please keep all discussion on the forum rather than PMs.  ;)

    @PM:

    We are facing an issue with Pfsense. when we setup Load balancing the Secure connection( Mainly HTTPS sites) is not working . It does not allow two public IP’s in same session, So it is being rejected.
    As per pfsense documentation available in net we tried to use “Sticky Connection” and also  tried to setup LAN rule for HTTPS but the issue is still not resolved.
    We are using Pfsense 1.2.2 version.
    We are  using  same IP for two different HTTPS  mail server.Actully the two mail server hosted into single Machine. Please let me know how  can I resolve the issue?

    Why are you running such an old version of pfSense?
    Your message is a bit confusing. Are you using inbound or outbound load balancing?

    Steve


Locked