Installation set up constantly returns to 'Do you want to set up VLANs first?'

  • I'm trying to install pfSense-2.0-RC3-i386-20110621-1650.iso on an Aleutia T1 computer.
    I'm using a WiFi dongle for WAN and the on-board ethernet for LAN.
    (My aim is to use an insecure WiFi network, for Internet access, and link to an OpenVPN with pfSense)

    On the set up it does state:
    'Network interface mismatch – Running interface assignment option'
    I don't know if this is significant.

    I answered 'n' to the VLAN prompt and it seemed to accept
    run0 as WAN (the WiFi dongle)
    re0 as LAN  (the on-board ethernet adapter)

    The problem is that is as far as it will go. It keeps returning to:-

    When I answer 'n' it zips through the WAN/LAN bit, of the set up, as it already has the info. and returns, again to:-
    'Do you want to set up VLANs first?'

    It is never ending.
    Can anyone please advise?

  • Rebel Alliance Developer Netgate

    What kind of network interfaces?

    Any errors in the system log once you get connected?

  • @jimp:

    What kind of network interfaces?

    Any errors in the system log once you get connected?

    Thank you for your reply.

    The system reports:-
    re0: RealTek 8168/8111 PCIe Gigabit Ethernet - set to LAN
    run0: Ralink RT3070, RF3020(MIMO 1T1R)      - set to WAN.
                It also reports RT2870 firmware loaded, for the Ralink,
                if I unplug the USB & plug it back in again.

    There is no established connection as yet because I plan, for testing purposes, to connect it to my router's WiFi which is WPA2 encrypted. I was hoping to get a bit further in the setup where I might be able to do some network settings. I may have to switch off the encryption, if needs be, to get it working.

    I got to the command prompt via ctl-c- I don't know if that is the accepted way.
    I tried to look at /var/log/system.log in 'vi' but it crashed. I must confess to being a bit 'fish out of water' with FreeBSD as I'm more used to Debian and use 'nano'.
    I noticed that 'ifconfig' was not recognised.

  • Rebel Alliance Developer Netgate

    It's probably got more to do with the usb network interface than anything else. Search the forum for references to runfw, I believe there is a loader setting you need in order for it to be properly recognized on each boot.

  • If you don't already have the line


    in /boot/loader.conf.local you should add it. If the file doesn't already exist create it.

    As jimp said, the run device doesn't become operational until after the firmware is loaded into the device. The firmware isn't in the kernel so it can't be loaded until the root file system is mounted and that happens after device recognition. The line in /boot/loader.conf.local causes the firmware to be loaded with the kernel. The boot loader has sufficient knowledge to the file system to find the kernel and the firmware file.

    I can't guarantee the suggested addition to /boot/loader.conf.local will fix your problem but it is highly likely to be a necessary component of the solution.

  • :) Thanks guys. I'll check it all out!