How can I tell if QoS is working for Asterisk?



  • Hey everyone, I just got pfsense up and running but I'm not 100% sure if it's working properly. I set it all up and ran the traffic shaping wizard, following a few guides online. I checked prioritize VoIP, and noticed I could ether just click Asterisk, or enter an IP. I first tried by entering my Asterisk IP, and I set that my max upload is 80% of my actual upload speed ans same with download. When I view queues, it would show phone calls on the WAN queue. I then reran the wizard and picked Asterisk to prioritize, and didnt enter an IP for it. This time now it shows when I make a call qVoIP has the traffic there which is good. The only thing is, if I do a speed test, I still get 100% up and down, it's not limiting it to 80% like I put in. Also, is there a way to tell if a VoIP call is being prioritized? The borrows, suspends and drops all stay at 0 the whole time. Not sure how to tell if this is working or not? My main concern is that my upload/download isn't being limited like it should so not sure?

    Thought I'd post my settings as well, these are what it shows on the screens, note that I didn't enter these manually. All I did in the wizard was say make my upload 1700kbps, my download 10700kbps and dedicate 96kbps bandwidth to IP calls.

    If I click WAN it says:

    Scheduler Type HFSC
    Bandwidth 1700 Kbps

    Under that it has qACK:
    Priority 6
    Bandwidth 18.87%
    Then service curve link share is checked at 18.87%

    qDefault is next under WAN
    Priority is 3
    Default queue is checked
    Explicit conjection notification is checked
    Bandwidth is 9.435%

    Then last under WAN is qVOIP
    Priority is 7
    Bandwidth it says 32Kbps
    Then under service curve it has real time checked and 96Kbps

    Then it has LAN:

    Scheduler type HFSC that's it

    under LAN there's qLink
    priortiy 2
    Queue limit 500
    Bandwidth 20%

    Then qInternet
    Bandwith 10700kbps
    Under service curve upper limit is checked at 10700kbps
    and link share is checked at 10700kbps

    under that there's qACK
    priortiy 6
    Bandwith 19.938%
    and service curve has link share checked at 19.938%

    Last under that there's qVoip

    Priority 7
    Bandwidth 32Kbps
    and service curve has real time checked and 96kbps in there.

    That's all the settings. Not sure why qVoip says 32Kbps is the bandwidth for the queue, but does that seem right or weird or?

    This is pfsense 2.0 RC3.

    I notice if I go to Queue Status here's the ones it shows in use while I'm downloading files etc online:

    qDefault on WAN
    qLink on LAN

    That's it. If I make a VoIP call, then qVoIP on LAN and qVoIP on WAN both show the voice call.

    qInternet, qACK, both never show they are being used and in my last message qInternet is the one that has the bandwidth limited so it's almost like it's using the wrong queue for Internet traffic but not sure?

    I also noticed that if I make an inbound call to our phone system, it shows it on qDefault as well, not qVoIP, only outbound calls are using qVoIP…... If I put myself on hold and do a speed test, outbound calls sound pretty much fine. If I do the same when calling in (when it's not directing to qVoIP), as soon as I hit the upload test the call gets incredibly choppy as well...

    Thanks so much!


Locked