Dual WAN PPPoE (DSL Connections) Connection keeps restarting



  • Hello,

    We have two DSL connections on WAN and OPT1 Interfaces. For some reason, on the WAN Interface I keep loosing connectivity every few hours (it may be less, have not really noticed). It will automatically connect within a few minutes.

    On the logs I have: (I X'ed out the IP's)

    Aug  1 19:27:46 pfsense check_reload_status: rc.newwanip starting pppoe0
    Aug  1 19:27:46 pfsense ppp: [wan] IFACE: Up event
    Aug  1 19:27:48 pfsense php: : rc.newwanip: Informational is starting pppoe0.
    Aug  1 19:27:48 pfsense php: : rc.newwanip: on (IP address: X.X.X.X) (interface: wan) (real interface: pppoe0).
    Aug  1 19:27:48 pfsense apinger: Exiting on signal 15.
    Aug  1 19:27:49 pfsense check_reload_status: Reloading filter
    Aug  1 19:27:49 pfsense apinger: Starting Alarm Pinger, apinger(48594)
    Aug  1 19:27:55 pfsense php: : Resyncing OpenVPN instances for interface WAN.
    Aug  1 19:27:55 pfsense php: : Creating rrd update script
    Aug  1 19:27:55 pfsense php: : OpenNTPD is starting up.
    Aug  1 19:27:55 pfsense php: : pfSense package system has detected an ip change 108.132.X.X ->   … Restarting packages.
    Aug  1 19:27:55 pfsense check_reload_status: Starting packages
    Aug  1 19:27:57 pfsense php: : Restarting/Starting all packages.
    Aug  1 19:28:49 pfsense apinger: Error while feeding rrdtool: Broken pipe
    Aug  1 19:28:49 pfsense apinger: /usr/local/bin/rrdtool respawning too fast, waiting 300s.
    Aug  1 19:29:41 pfsense ppp: caught fatal signal term
    Aug  1 19:29:41 pfsense ppp: [wan] IFACE: Close event
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: Close event
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: state change Opened –> Closing
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: SendTerminateReq #16
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: LayerDown
    Aug  1 19:29:41 pfsense check_reload_status: Rewriting resolv.conf
    Aug  1 19:29:41 pfsense ppp: [wan] IFACE: Down event
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: rec'd Terminate Ack #16 (Closing)
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: state change Closing –> Closed
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: LayerFinish
    Aug  1 19:29:41 pfsense ppp: [wan] Bundle: No NCPs left. Closing links…
    Aug  1 19:29:41 pfsense ppp: [wan] Bundle: closing link "wan_link0"…
    Aug  1 19:29:41 pfsense ppp: [wan_link0] LCP: rec'd Terminate Request #181 (Opened)
    Aug  1 19:29:41 pfsense ppp: [wan_link0] LCP: state change Opened –> Stopping
    Aug  1 19:29:41 pfsense ppp: [wan_link0] Link: Leave bundle "wan"
    Aug  1 19:29:41 pfsense ppp: [wan] Bundle: Status update: up 0 links, total bandwidth 9600 bps
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: Close event
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: Down event
    Aug  1 19:29:41 pfsense ppp: [wan] IPCP: state change Closed –> Initial
    Aug  1 19:29:41 pfsense ppp: [wan_link0] LCP: SendTerminateAck #14
    Aug  1 19:29:41 pfsense ppp: [wan_link0] LCP: LayerDown
    Aug  1 19:29:41 pfsense ppp: [wan_link0] Link: CLOSE event
    Aug  1 19:29:41 pfsense ppp: [wan_link0] LCP: Close event
    Aug  1 19:29:41 pfsense ppp: [wan_link0] LCP: state change Stopping –> Closing
    Aug  1 19:29:43 pfsense ppp: [wan] Bundle: Shutdown
    Aug  1 19:29:43 pfsense ppp: [wan_link0] Link: Shutdown
    Aug  1 19:29:43 pfsense ppp: process 12596 terminated
    Aug  1 19:29:45 pfsense ppp: Multi-link PPP daemon for FreeBSD
    Aug  1 19:29:45 pfsense ppp:
    Aug  1 19:29:45 pfsense ppp: process 54294 started, version 5.5 (root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org 15:09 21-Jul-2011)
    Aug  1 19:29:45 pfsense ppp: web: web is not running
    Aug  1 19:29:45 pfsense ppp: [wan] Bundle: Interface ng0 created
    Aug  1 19:29:45 pfsense ppp: [wan_link0] Link: OPEN event
    Aug  1 19:29:45 pfsense kernel: ng0: changing name to 'pppoe0'
    Aug  1 19:29:45 pfsense ppp: [wan_link0] LCP: Open event
    Aug  1 19:29:45 pfsense ppp: [wan_link0] LCP: state change Initial –> Starting
    Aug  1 19:29:45 pfsense ppp: [wan_link0] LCP: LayerStart
    Aug  1 19:29:45 pfsense ppp: [wan_link0] PPPoE: Connecting to '*'
    Aug  1 19:29:45 pfsense ppp: PPPoE: rec'd ACNAME "FTLDFLPL63W-8Y034090501571"
    Aug  1 19:29:46 pfsense ppp: [wan_link0] PPPoE: connection successful
    Aug  1 19:29:46 pfsense ppp: [wan_link0] Link: UP event
    Aug  1 19:29:46 pfsense ppp: [wan_link0] LCP: Up event
    Aug  1 19:29:46 pfsense ppp: [wan_link0] LCP: state change Starting –> Req-Sent

    Not sure if you need any more logs to diagnose.
    I'm using Today's build.
    Thanks!



  • Aug  1 18:14:34 pfsense php: : Restarting/Starting all packages.
    Aug  1 18:15:25 pfsense apinger: Error while feeding rrdtool: Broken pipe
    Aug  1 18:15:25 pfsense apinger: /usr/local/bin/rrdtool respawning too fast, waiting 300s.
    Aug  1 19:16:22 pfsense apinger: ALARM: WAN(108.132.X.X)  *** down ***
    Aug  1 19:16:32 pfsense check_reload_status: Reloading filter
    Aug  1 19:16:32 pfsense ppp: [wan_link0] LCP: no reply to 1 echo request(s)
    Aug  1 19:16:42 pfsense ppp: [wan_link0] LCP: no reply to 2 echo request(s)
    Aug  1 19:16:51 pfsense apinger: alarm canceled: WAN(108.132.X.X))  *** down ***
    Aug  1 19:17:01 pfsense check_reload_status: Reloading filter
    Aug  1 19:18:21 pfsense apinger: ALARM: WAN(108.132.X.X)  *** loss ***
    Aug  1 19:18:31 pfsense check_reload_status: Reloading filter
    Aug  1 19:19:17 pfsense apinger: alarm canceled: WAN(108.132.X.X))  *** loss ***
    Aug  1 19:19:27 pfsense check_reload_status: Reloading filter
    Aug  1 19:25:27 pfsense apinger: ALARM: WAN(108.132.X.X))  *** down ***
    Aug  1 19:25:34 pfsense apinger: alarm canceled: WAN(108.132.X.X))  *** down ***
    Aug  1 19:25:37 pfsense check_reload_status: Reloading filter
    Aug  1 19:25:44 pfsense check_reload_status: Reloading filter
    Aug  1 19:25:44 pfsense apinger: ALARM: WAN(108.132.X.X))  *** down ***
    Aug  1 19:25:54 pfsense check_reload_status: Reloading filter
    Aug  1 19:26:02 pfsense ppp: [wan_link0] LCP: no reply to 1 echo request(s)
    Aug  1 19:26:12 pfsense ppp: [wan_link0] LCP: no reply to 2 echo request(s)
    Aug  1 19:26:22 pfsense ppp: [wan_link0] LCP: no reply to 3 echo request(s)
    Aug  1 19:26:32 pfsense ppp: [wan_link0] LCP: no reply to 4 echo request(s)
    Aug  1 19:26:42 pfsense ppp: [wan_link0] LCP: no reply to 5 echo request(s)
    Aug  1 19:26:42 pfsense ppp: [wan_link0] LCP: peer not responding to echo requests
    Aug  1 19:26:42 pfsense ppp: [wan_link0] LCP: state change Opened –> Stopping
    Aug  1 19:26:42 pfsense ppp: [wan_link0] Link: Leave bundle "wan"
    Aug  1 19:26:42 pfsense ppp: [wan] Bundle: Status update: up 0 links, total bandwidth 9600 bps
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: Close event
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: state change Opened –> Closing
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: SendTerminateReq #12
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: LayerDown
    Aug  1 19:26:42 pfsense check_reload_status: Rewriting resolv.conf
    Aug  1 19:26:42 pfsense ppp: [wan] IFACE: Down event
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: Down event
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: LayerFinish
    Aug  1 19:26:42 pfsense ppp: [wan] Bundle: No NCPs left. Closing links…
    Aug  1 19:26:42 pfsense ppp: [wan] IPCP: state change Closing –> Initial
    Aug  1 19:26:42 pfsense ppp: [wan_link0] LCP: SendTerminateReq #10
    Aug  1 19:26:42 pfsense ppp: [wan_link0] LCP: LayerDown
    Aug  1 19:26:44 pfsense ppp: [wan_link0] LCP: SendTerminateReq #11
    Aug  1 19:26:46 pfsense ppp: [wan_link0] LCP: state change Stopping –> Stopped
    Aug  1 19:26:46 pfsense ppp: [wan_link0] LCP: LayerFinish
    Aug  1 19:26:46 pfsense ppp: [wan_link0] PPPoE: connection closed
    Aug  1 19:26:46 pfsense ppp: [wan_link0] Link: DOWN event
    Aug  1 19:26:46 pfsense ppp: [wan_link0] LCP: Down event
    Aug  1 19:26:46 pfsense ppp: [wan_link0] LCP: state change Stopped –> Starting
    Aug  1 19:26:46 pfsense ppp: [wan_link0] LCP: LayerStart
    Aug  1 19:26:46 pfsense ppp: [wan_link0] Link: reconnection attempt 1 in 2 seconds
    Aug  1 19:26:48 pfsense ppp: [wan_link0] Link: reconnection attempt 1
    Aug  1 19:26:48 pfsense ppp: [wan_link0] PPPoE: Connecting to ''
    Aug  1 19:26:57 pfsense ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Aug  1 19:26:57 pfsense ppp: [wan_link0] Link: DOWN event
    Aug  1 19:26:57 pfsense ppp: [wan_link0] LCP: Down event
    Aug  1 19:26:57 pfsense ppp: [wan_link0] Link: reconnection attempt 2 in 3 seconds
    Aug  1 19:27:00 pfsense ppp: [wan_link0] Link: reconnection attempt 2
    Aug  1 19:27:00 pfsense ppp: [wan_link0] PPPoE: Connecting to '
    '



  • Never mind, seems to be an ISP issue.


Locked