Adding bridge -> nothing happens



  • Hello everyone.

    I want to set up bridge between two interfaces (LAN and OPT2). I read some topics,  but without success.
    When I go to >Interfaces>assign>bridges and I select two interfaces and then click save, it is everything like it was before. There is no new bridge.

    Firmware version: 2.0-RC3 (i386) built on Wed Aug 3 19:24:43 EDT 2011
    Both NICs are Intel Pro 10/100/1000.

    LAN interface: enabled, static IP and DHCP enabled
    OPT2 interface: enabled, none
    Can somebody help me with this problem, because I don't know what to do.

    Here is system log:

    Aug 4 10:01:03	apinger: Starting Alarm Pinger, apinger(33274)
    Aug 4 10:01:03	check_reload_status: Reloading filter
    Aug 4 10:01:02	apinger: Exiting on signal 15.
    Aug 4 10:01:02	php: : Removing static route for monitor 8.8.8.8 and adding a new route through 192.168.2.1
    Aug 4 10:01:02	check_reload_status: Configuring interface opt2
    Aug 4 10:01:02	php: : rc.newwanip: Failed to update opt2 IP, restarting...
    Aug 4 10:01:02	php: : rc.newwanip: on (IP address: ) (interface: opt2) (real interface: em1).
    Aug 4 10:01:02	php: : rc.newwanip: Informational is starting em1.
    Aug 4 10:01:02	php: : rc.newwanip: on (IP address: 10.0.0.1) (interface: lan) (real interface: em0).
    Aug 4 10:01:02	php: : rc.newwanip: Informational is starting em0.
    Aug 4 10:00:59	check_reload_status: rc.newwanip starting em1
    Aug 4 10:00:59	php: : Hotplug event detected for opt2 but ignoring since interface is configured with static IP ()
    Aug 4 10:00:58	check_reload_status: rc.newwanip starting em0
    Aug 4 10:00:58	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (10.0.0.1)
    Aug 4 10:00:57	php: : Hotplug event detected for opt2 but ignoring since interface is configured with static IP ()
    Aug 4 10:00:56	kernel: em1: link state changed to UP
    Aug 4 10:00:56	check_reload_status: Linkup starting em1
    Aug 4 10:00:56	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (10.0.0.1)
    Aug 4 10:00:56	kernel: em0: link state changed to UP
    Aug 4 10:00:56	check_reload_status: Linkup starting em0
    Aug 4 10:00:54	check_reload_status: Syncing firewall
    Aug 4 10:00:53	php: /interfaces_bridge_edit.php: The command '/sbin/ifconfig bridge7 addm 'em1'' returned exit code '1', the output was 'ifconfig: BRDGADD em1: Device busy'
    Aug 4 10:00:53	kernel: em1: link state changed to DOWN
    Aug 4 10:00:53	check_reload_status: Linkup starting em1
    Aug 4 10:00:53	php: /interfaces_bridge_edit.php: The command '/sbin/ifconfig bridge7 addm 'em0'' returned exit code '1', the output was 'ifconfig: BRDGADD em0: Device busy'
    Aug 4 10:00:53	kernel: em0: link state changed to DOWN
    Aug 4 10:00:53	check_reload_status: Linkup starting em0
    


  • There seems to be some issues with your interfaces there!



  • @voluhar:

    I want to set up bridge between two interfaces (LAN and OPT2). I read some topics,  but without success.
    When I go to >Interfaces>assign>bridges and I select two interfaces and then click save, it is everything like it was before. There is no new bridge.

    From memory, what you have done is just create the bridge and you still need to go back to Interfaces -> (assign) and click on the "+" button to add the newly created bridge interface to the list of interfaces available to pfSense.

    Your log output reports a failure adding the two member interfaces to the bridge: devices reported busy. Maybe it would be worth rebooting so the bridge can have its members added early in the system startup.



  • @wallabybob:

    From memory, what you have done is just create the bridge and you still need to go back to Interfaces -> (assign) and click on the "+" button to add the newly created bridge interface to the list of interfaces available to pfSense.

    Actually I can't create a bridge…

    It is something really strange happening with my pfSense. I will play with it tomorrow, factory default and then fresh install.

    I rebooted it (some times) and I can't even change network port on interface, like it wont save changes. In system log is nothing useful for me about that.

    If I create enough interfaces that I got 2 vlans for OPT6 and OPT7, and try to create is system log like this:```
    Aug 4 21:29:05 check_reload_status: Syncing firewall
    Aug 4 21:29:05 kernel: rl0_vlan102: promiscuous mode enabled
    Aug 4 21:29:05 kernel: rl0_vlan101: promiscuous mode enabled

    
    Probably is playing with that install waste of time but if anybody need that I try something before factory default just tell me.


  • Maybe related to the same problem I have with assigning interfaces? See: http://forum.pfsense.org/index.php/topic,39588.0.html
    It will be fixed in a new snapshot, I will certainly try.



  • @woc38:

    Maybe related to the same problem I have with assigning interfaces? See: http://forum.pfsense.org/index.php/topic,39588.0.html
    It will be fixed in a new snapshot, I will certainly try.

    I read your topic while system was updating to 2.0-RC3 (i386) built on Thu Aug 4 12:47:50 EDT 2011.
    So after updating problem was solved.

    Just one more question… Is it normal that you have to reboot if you want to apply changes?



  • What is the reason you have to reboot?



  • It has been my experience that most changes don't need a reboot to take effect. One exception I can recall (but this was months ago and I'm not sure of all the details): I changed my LAN IP address to a different subnet and then couldn't access the web GUI. I rebooted. I suspect I could have avoided the reboot if I played around a little more.

    Firewall rule changes sometimes need a little dance to take effect - see Diagnostics -> States, click on the Reset States tab and read the explanation.



  • I was reading this http://forum.pfsense.org/index.php?topic=20917.0

    1. Start box with WAN1 (vr0) - PPOE, WAN2(dc0) - DHCP, LAN(em1) - stattic
    2. Add OPT2(em0) and OPT3(rl0) interface
    3. Enable OPT2 and OPT3 interface, apply changes
    4. Create bridge OPT2 + OPT3
    5. Selecet BRIDGE0 as LAN port and em1 as OPT3 port
    6. Save settings

    So at that point I had to reboot If I want working network.



  • I can not stress it enough.

    You can assign the bridge as anything else with the same results it is not necessary for it to be LAN!



  • @ermal:

    I can not stress it enough.

    You can assign the bridge as anything else with the same results it is not necessary for it to be LAN!

    I hope that we understand each other…(and that my English isn't to bad)...

    Well It isn't clear to me why I had to restart pfSense at point 6. Because before system restart pfSense doesn't respond to ping and after it does. After restart I doesn't change anything.
    Maybe should be there checkbox or something to enable automatic restart if it is needed.


Locked