• Hi all,
    I have the latest snapshot and openntpd doens't work. I have nothing in the logs. I try to disable et enable openntpd and nothing.
    In windows I can't update time, i have an error, it's same on linux server …
    An idea ?
    Thanks


  • Me too:
    1.0.1-SNAPSHOT-02-21-2007
    built on Sat Feb 24 03:13:03 EST 2007

    I've had to point all my boxes at the internet, rather than pull from pfSense.


  • Based on a quick glance of

    /usr/local/pkg/openntpd.inc

    The openntpd_install() function is never called because the openntpd package is part of the core distribution now (at least in the recent snapshots of 2007).  Hence the openntpd.sh script in /usr/local/etc/rc.d is never created.

    Ideally the write_rcfile() call should be moved elsewhere in the code that is normally executed.

    I've moved the code around in my test dev system, and now openntpd.sh generates and the server responds.

    The developers probably just need to spent a minute to refactor the code on the next commit.  I'd post a patch diff, but I'm still learning how things are done in the pfsense code base before I become more involved in helping out.


  • @patord:

    …  I'd post a patch diff, but I'm still learning how things are done in the pfsense code base before I become more involved in helping out.

    read http://wiki.pfsense.com/wikka.php?wakka=SubmittingPatches once you are able to send in patches  ;)


  • Will a fix for this be incorperated into 1.2 rc 3?
    im currently using 1.2 rc2 its yet to auto sync with the exception of first boot for 13 days now.
    Ive been logging in through ssh to force a sync the past two days