Latest updates for AMD64 (64-bit) not liking DNS?



  • First an apology:  I'm not technical, just curious!

    I've been working away on version pfSense-2.0-RC3-amd64-20110621-2308 for some time without any issues, apart from myself breaking things, I've just reverted back to my last known working ISO image but now thought it better to upgrade!

    The latest update was showing as: pfSense-Full-Update-2.0-RC3-amd64-20110805-1829, so I hit the upgrade button and went for a nice cuppa tea and biscuit….. came back to see that pfSense had picked up an IP address for my WAN-PPPoE connection, but it didn't update any of my packages.  Logged onto the GUI and "Widescreen" package was all over the place and the "Dashboard" showing "Unable to check for updates.", tried surfing the Interweb, but nothing, tried updating the packages, nothing, tried pinging www.pfsense.org, nothing.

    So, loaded up my last known working ISO image, pfSense-2.0-RC3-amd64-20110621-2308.iso and ran it from the CD-ROM image, logged into the GUI and changed the WAN-DHCP to WAN-PPPoE, checked Status:Interfaces" and the WAN-PPPoE had picked up an IP address, "Dashboard" now showing "Update available. Click Here to view update.".  So I note the DNS settings "System:General Setup", blank for "DNS Server" and none for "Use Gateway", there is a "check mark" for Allow DNS server list to be overridden by DHCP/PPP on WAN .  Unplugged the CD-ROM drive and booted back into pfSense-Full-Update-2.0-RC3-amd64-20110805-1829, again it couldn't find any package updates, again the WAN-PPPoE connection picked up an IP address.  Logged into the GUI, but again "Dashboard" showing "Unable to check for updates.", unable to surf the Interweb or update the packages or ping www.pfsense.org.  "System:General Setup" showing exactly the same as my last known working ISO image.

    So, I booted back into the pfSense-2.0-RC3-amd64-20110621-2308.iso, went surfing to http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_RELENG_2_0/updates/?C=M;O=D and started downloading some updates…..

    Downgraded to:  pfSense-Full-Update-2.0-RC3-amd64-20110801-1416.tgz - Unable to surf the Interweb, no DNS/DNS Issue?
    Downgraded to:  pfSense-Full-Update-2.0-RC3-amd64-20110731-0208.tgz - Unable to surf the Interweb, no DNS/DNS Issue?
    Downgraded to:  pfSense-Full-Update-2.0-RC3-amd64-20110728-0359.tgz - Working DNS! :)

    Tried full ISO image:  pfSense-2.0-RC3-amd64-20110805-1956.iso - Unable to surf the Interweb, no DNS/DNS Issue?
    Tried full ISO image:  pfSense-2.0-RC3-i386-20110805-1130.iso - Working DNS! :)

    So, the latest i386 image is working but I can't get the latest AMD64 image working, this is where someone will come along and say tick this little box here and everything should spring into life…  if not then what can I do (log files etc.) to help you guys to help me get the latest AMD64 version working?



  • I suspect you're seeing http://redmine.pfsense.org/issues/1759



  • CMB,

    Thanks, I didn't see that before I post here, I've udpated the redmine ticket with my limited problem determination.



  • I've just updated to pfSense-Full-Update-2.0-RC3-amd64-20110810-1042.tgz and everything is working OK.

    ;D


Locked