XMLRPC problem, 2.0-RC3 (amd64)



  • We are having a problem setting up XMLRPC.
    The first firewall in the cluster is configured, has VIP, pfsync and CARP set up. The second has a complete interface configuration, a rule to pass traffic on the sync interface and pfsync configured.
    Now, pfsync seems to work as we see its traffic when we do a packet capture. However XMLRPC doesn't synchronize any changes to the second firewall. We have logging enabled on the 'allow any' rule on both machines, and we see absolutely no traffic on both machines on the sync interface. When we do a packet capture we see only pfsync traffic, and no xmlrpc traffic. Furthermore, no errors are listed in the system logs.

    We have tried a lot, like using a different interface, rebooting the machines etc. but nothing seems to work, no errors, no sync. Both systems are exactly the same version (2.0-RC3 (amd64) built on Mon Aug 8 18:38:15 EDT 2011), no packages are installed on either machine.


  • Rebel Alliance Developer Netgate

    Show the config from Firewall > Virtual IPs, on the CARP Settings tab on both the master and slave.

    If you have the config sync properly configured there, it should be trying, and if it can't do it, it alerts you in the GUI.



  • I've attached the CARP settings of both machines. Note that both machines can reach each other by ping on the given IP's. Also there exists a rule on both machines allowing all traffic on the interface concerned. None of the usual messages appear in the GUI (I've seen them before). Also still nothing in the system logs, nor do i see anything else than pfsync traffic when i do a packet capture.

    ![Carpsettings Backup.JPG_thumb](/public/imported_attachments/1/Carpsettings Backup.JPG_thumb)
    ![Carpsettings Backup.JPG](/public/imported_attachments/1/Carpsettings Backup.JPG)
    ![Carpsettings Master.JPG_thumb](/public/imported_attachments/1/Carpsettings Master.JPG_thumb)
    ![Carpsettings Master.JPG](/public/imported_attachments/1/Carpsettings Master.JPG)


Locked