Can´t get my head around siproxd



  • We have 6 Cisco SPA504G that connects to a swedish provider called Telavox.

    When a phone shows up under Cuurntly registered phones in the siproxd the state 5060 for that phones gets NO_TRAFFIC:SINGLE while the non-registered ones have MULTIPLE:MULTIPLE. The other day I almost went mad when all phones were registered and all phones had the state NO_TRAFFIC:SINGLE, but after a firmware update and a reboot all but one phone got the MULTIPLE:MULTIPLE as I understand from this guide http://forum.pfsense.org/index.php/topic,10084.0.html is the correct state.

    There wouldn´t be a problem if it wasn´t for the link from the pfsense firewall to my provider drops after like 15 minutes or so and I have to make a call from one of the phones before anyone can call in to any of the phones.

    There are no real documentation on what the Registered Phones feature is and how to control the states anywhere. Can somebody who knows shed some light over this? I really want to understand this and if there is a way to choose the state of my phones.

    Cheers and thanks for any help!
    //Peter



  • So I have done some more testing and discovered that if I use static port in outbound NAT, the phones will turn up in Registered Phones and the state get NO_TRAFFIC:SINGLE. As I can see the proxy has a MULTIPLE:MULTIPLE connection to the provider. So that is fine for now.

    Now the only problem I have is that even though I run the firewall in conservative mode the connection to the provider times out and this render in that no one can phone in from the outside, until someone on the inside make an outbound call and get the connection up again between the proxy and the provider.

    I could turn of the static setting in the outbound NAT rule but then only one phone can be used at a time. To use more than one phone I need the proxy and then I have the time out problem.

    So even though I have read hundreds of pages about this I have yet to find a setting for how to extend the connection to the provider. Is there a way to set the timeout for this?

    Thank you for any responses.
    //Peter


  • Rebel Alliance

    I've been playing with some PAP2, SPA2102/3102 & siproxd, and find that you must have to play with this settings:

    ( in LINE Settings )
    NAT Keep Alive Enable: "YES"
    NAT Keep Alive Dest: "Your SIP provider ip"
    NAT Keep Alive Msg: "$NOTIFY"

    ( in SIP Settings )
    NAT Keep Alive Intvl: "50"

    With that settings my ATA`s works fine.



  • Ok thanks!

    I got the phones from the provider preprogrammed and password locked but I will have chat with their support and see if we can sort it out so the phones gets proper settings.

    Everything has worked flawless though sine the firmware upgrade and reboot as I wrote about in my last reply, so for now I am quite happy.

    Cheers!

    //Peter


Locked