Installing pfSense on an older machine



  • Hey, I've run into some troubles installing pfSense on an older desktop i have sitting around (HP s7421c). I've been trying from the 2.0-RC3-i386 live CD, which boots fine. I tried installing it many times with a variety of errors and problems. It will either get stuck at the first boot loader screen with a stuck spinner \

    After messing around with it for a while ACPI on or off doesn't make a difference, it seems to prefer having "packet mode" turned on in the bootblocks, when packet mode is turned on it will go past the bootloader screen, and will (sometimes, on the odd install) just be unable to find /boot/loader and /boot/kernel/kernel.

    Sometime at the beginning and earlier in the night it was getting into the pfSense boot screen (boot normally, boot no acpi, boot usb, etc) and then get stuck on the spinner after that.

    I know there isn't a hardware issue because i was running the machine as a mini linux server for 2 years up until today when i decided to repurpose it as a better router. So i'm really not sure why it's not working.


  • Netgate Administrator

    Stuck at the spinner is often a result of the bios reporting the hard drive size incorrectly.
    You could try:
    Entering the hard drive parameters manually in the bios.
    Using a smaller hard drive.
    Using a smaller, ~4GB, partition to boot from.

    See: http://doc.pfsense.org/index.php/Boot_Troubleshooting

    Steve



  • Well the drive is 250gb, and i was thinking this could possibly be a problem with it not being able to boot off a disk over 128gb. How would i go about setting up a smaller boot partition, i tried it once in the pfsense installer, but i wasn't quite able to figure out how to make it work with the options provided. Or would i have to go about doing it outside of the installer perhaps? By partitions, do you mean actual partitions, or BSD slices?

    I had found that boot troubleshooting page previously and tried some things on there related to stuck spinners. But none of it offered real solutions.


  • Netgate Administrator

    Are you using the latest bios version?

    I'm only running the NanoBSD version, no partitioning or installation required, so I'm unfamiliar with the install process.

    Steve



  • yeah, it's running the latest bios version that i can find.



  • Suggestion: In your BIOS make sure the disk controller is not in RAID mode or AHCI mode or SATA mode or advanced or … Go for LEGACY IDE (or as close to "old fashioned hard drive" as you can. I don't know what options your BIOS offers). Maybe the disk controller mode will make a difference.


  • Netgate Administrator

    I think your idea of 'an older machine' differs from mine.
    The computer I am typing this on, the fastest machine available to me, is a Pentium 4 2.8GHz with 1GB ram.
    I have another machine that use regularly for compiling and such which is a Celeron 666MHz.
    Admittedly I usually use a laptop with a CoreDuo but the hard drive failed on Saturday and I'm waiting for a replacement!  ::)
    I should have looked up the spec of your machine first.  :-[

    Reading back through this thread though I see that 250GB is what HP supplied with this machine so you'd hope the bios would be correctly recognising it.
    I [url=http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00590366&tmp_task=prodinfoCategory&cc=us&dlc=en&document=&lc=en&product=1849529]see that this board has no IDE connectors either so your stuck with SATA which is less well supported by FreeBSD, though still shouldn't be a problem.

    I see that there's a firmware update for the original Samsung HD to improve compatibility if your still using that.

    Steve



  • When i tried making a /boot slice in the installer the installer throws an error

    /sbin/mount -o rw /dev/ad0s1a /mnt/boot
    
    Failed with return code of 1
    
    

    when i view the log it reports that mount says the disk is busy. Not really sure what i could do. Tried updating the disk's firmware, this test is with it after. Tried a quick install, no beans.
    I even tried booting a gParted disk, and creating the disk's partitions with that, it installed fine onto the disk, but now won't boot once again. gParted had made the partition with different geometry than the pfsense installer wanted to, but it still won't boot off the disk.


  • Netgate Administrator

    Was the partition under 4GB?
    Have you tried setting the disk geometry in the bios, perhaps to that suggested by gParted?

    Steve



  • bios doesn't have any settings for disk geometry, the partition i tried was 10GB i think. I could retry with one under 4.


  • Netgate Administrator

    I forget what the exact reason was for using a 4gb partiton, something to do with the addressing, but I'd give that a go.
    Will it boot from USB? You can run the NanoBSD image from a usb stick.  :)

    Steve



  • Steve: I was thinking the same thing–my pfSense installation here at the motel I work at is running on an old AMD K6 with 128MB of RAM and a tiny hard drive.  OP's machine, for this purpose, is anything BUT old! :)

    As for the OP: I don't see why a machine made in 2006 and probably using SATA would have any trouble at all with a 250GB drive.  If they're using older or odd chips or BIOS firmware (this IS HP, after all...), I suppose it could be a problem as I've had *BSD bootloaders fight with some BIOSes, especially my laptop (but LILO works fine--again, weird).

    If the machine still has PATA (old IDE) interfaces, try a 40GB or smaller drive: they're cheap enough to throw away and far larger than the entire pfSense install, anyway.  You can even, if you're feeling brave, install an FTP or WWW server inside a jail to use some of that space, if you want, especially with a humungous 1GB of RAM in that thing. (Of course, you didn't mention what kind of network speeds we're talking here...)

    Finally, I've also had problems in the past with corrupted images, either with a bad CD burn or with the download itself being bad.  I strongly recommend you verify your ISO against its MD5 hash to be sure it's ok.  This is especially true with snapshots, which I've had regular problems with (that is, when I do an auto-upgrade, the downloaded file does not match its MD5 hash, and the corruption turns out to be on the server since re-downloading it does not solve the problem, but the next snapshot is fine).

    Mike



  • i haven't had a chance to try out the 4gb partition yet, but i will soon. unfortunately the only small disk other than the 250gb in there i have is a 250gb ide disk, somewhere. I did verify the ISO against the sha signature to be sure, and it did verify fine.

    It will be routing a 32mbit connection right now, and later prolly a 50+mbit connection, but we also now need QoS, to which i didn't feel like trying to find a home/soho router that could actually handle that, and decided just to throw hardware at the issue. I'll try some of the suggested fixes later tonight if not tomorrow (been so busy at work lately x.x)


  • Netgate Administrator

    One further thing to try is to install a different boot loader that isn't reliant on your bios for the hard drive geometry. This is more complicated but can get almost anything to boot.  :)
    See this post for example: http://forum.pfsense.org/index.php/topic,31808.0.html

    Steve



  • I am definitely going to try with that alternate bootloader tonight.



  • Well alright, i have some news on this finally. It's not misbehaving so much with the bootloader anymore, but yet still is. It's not stalling on the spinner anymore on initial boot, but i'm getting

    error 1 lba 337964399
    

    from the bootloader, also reporting it not able to find /boot/loader or /boot/kernel/kernel. I tried with the alternate bootloader, GAG aswell as pretty much every other one off the UBCD, and they all dump me back to the bsd bootloader error screen i get that previous lba error on.

    Now i tried booting off a partition <4gb (3.81gb or something to be precise…) and it worked fine. So now if i can figure out how to just get /boot onto a slice < 4gb and the rest of the install onto the rest of the disk, i'd be great. perhaps i might have to mess with it in a tool that can mount the bsd partitions and play around with the files on it, so i can move /boot to another slice or something and whatnot.



  • finally got it working with partitions looking like this:

    
    4Gb /
    50Gb /usr
    * /var
    2G swap
    
    

    So, hopefully this might help people later with stubborn installs. Didn't end up needing an alternate bootloader for it.



  • I get a full pfSense install into a 1GB SSD with plenty of space left over. I ran only a small number of packages. Some packages would require a much larger drive.


Locked