Change monitor interval removed?


  • Rebel Alliance Global Moderator

    I do believe awhile back it was added to be able to set the monitor time for each gateway to something other than the 1 second default, I had mine set to 10 seconds.  But now that option seems to be missing?



  • System: Gateways: Edit gateway
    Advanced: Frequency Probe
    This defines the frequency in seconds that an icmp probe will be sent. Default is 1 second.

    I hopse this is what you want.
    2.0-RC3 (amd64)
    built on Mon Aug 8 18:38:15 EDT 2011


  • Rebel Alliance Global Moderator

    yup that is where it was ;)

    but I don't have that anymore?? see attached.




  • Hmm - there isn't any "advanced" button, right ?
    Which snapshot are you on ? I am on 8th august amd64.


  • Rebel Alliance Global Moderator

    Well the snapshot more than likely not the issue, I do not update that very often - but I do gitsync pretty much every few days.  Problem is I do not recall exactly when it went away.

    I am currently on
    2.1-DEVELOPMENT (i386)
    built on Wed Jul 27 13:28:34 EDT 2011

    My last gitsync was this morning, but I noticed it missing before that.

    I remember the commit that added it, I will have to walk back through the commits and see if it was taken back out or some other commit broke it?  I can update the snapshot when I get home tonight, don't like doing that remote - but I don't believe that will fix it, but will do to rule out.

    So here is the commit that added the feature
    https://github.com/bsdperimeter/pfsense/commit/f720398561237cf0032d41f83c35e443d2acaf66
    dated July 28, 2011

    I will scan through and see if I see anything that stated it would revert that.



  • Probably you should try the 2.0 branch


  • Rebel Alliance Global Moderator

    What?  And then how would I have my ipv6 support?

    I just checked the commit and the files have the changes in them, seems some other commit broke the display of it on the gui?

    Ok uplooking at the source of the page, looks like not seeing the button that should be there??

    
     - Show advanced option
    
    

  • Rebel Alliance Global Moderator

    Ok still no advanced button, why??

    I am up to date with commits as of this morning.

    I can get it to show if I edit this line in system_gateways_edit.php line 404

    
     1) || (isset($pconfig['interval']) && $pconfig['interval'])) echo "style='display:none'"; ?>>
    
    to say display:block vs none - which makes sense.  But there why is it not set to that on its own.
    
    Shouldn't this button be shown all the time, why hide it if something is not set?
    

Locked