WiFi, I have something set up wrong.



  • Hello all,

    I need my WiFi to act like a wired client because I have devices talking to each other on my network that can't handle a hop.

    Ok, I have the lan set to bridge and the WiFi set to athr0.

    When ever I upgrade or reboot, I have to reapply these settings, then link through the serial port and re-apply the IP address to the Lan again to get it working, but if I reboot or upgrade only the WiFi works till I relink through the serial and apply all over again.

    How should I have this set up so I get Wired and WiFi Lan though the same DHCP?

    Thanks!



  • What are the members of the bridge?
    How you have assigned your wired network?

    My first guess is that you had assigned wired as LAN and then overwrote that with changing the assignment to bridge!



  • @ermal:

    What are the members of the bridge?
    How you have assigned your wired network?

    My first guess is that you had assigned wired as LAN and then overwrote that with changing the assignment to bridge!

    My bridge members are LAN, WiFi.

    I had my wired network as VR1.

    Right now my WAN is VR0
    My LAN is bridged and my WiFi is ATH0

    How should I assign them?

    Or going back to square one, how do I set up my WiFi to grab from the same DHCP pool as my LAN(wired) systems and keep everything on the same subnet so all systems can talk to each other?

    Thanks!



  • Can anyone please tell me how to properly set this up?

    I don't think it's that unusual.

    Thanks,



  • @Honeybadger:

    When ever I upgrade or reboot, I have to reapply these settings,

    I have a configuration similar to what you say you want but I don't have to reapply settings on every reboot.

    Please give more details of what you mean by reapply these settings: you have to reassign interfaces from the console during startup? you have to tweak some settings through the web GUI?

    What is the prompt that tells you the settings need  to be reapplied: the console startup says Reapply settings? After you login through the web GUI a popup says Reapply Settings? WiFi clients don't get an address through DHCP?

    Exactly what settings are reapplied? Does "reapply" mean "set to existing value and save"?



  • Nothing tell me that I have to reapply except that my LAN is unreachable after a reboot.

    When I reboot the unit, I can only contact the network through WiFi, LAN is unreachable. I then have to log into my router by wifi to the router's IP over WiFi to get to the GUI, and hit save on the bridge being on Lan and the WiFi being ATH0 in interfaces. I then lose WiFI, at which point I have to plug in the serial cable directly to my router which I then can re-apply the LAN IP as which point everything comes back up till the next reboot.

    I have completely formated and re-applied a freshly downloaded embredded image 3 times with the same results everytime so I don't have a bad image or something.

    1.2.3 didn't act this way, this is new with 2.0 RC3.

    Thanks,



  • There is an easy physical layer solution to your problem.

    1. Setup wireless configuration of your wi-fi
    1. Disable the DHCP server in your Wireless router.
    2. Set wireless router to that the LAN IP is in same IP range as your wired network (for future management)
    3. Connect from your switch to the switchport on back of your wirless router (Not WAN port)
    4. You should be good to go everyone (wired port on switch, and Wi-Fi Router) should be in the same broadcast domain

    If you do it this way you don't have to bother with a bridge and you are just using your Wi-Fi device as an access point and a switch.
    Not sure about your equipment you might have to make a crossover cable to connect from switchport to switchport.

    Goodluck let me know how you make out.



  • Mike, you are very kind.

    I think I gave a wrong impression.

    My WiFi is just another interface on my Soekris/PFsense "Router", I have a WiFi card in the unit that it is using to broadcast a 802.11b signal. on the PFSense server (for lack of a better term) I have 3 interfaces, WAN, LAN and WiFI. The Lan is set to Bridged0, the WiFi is set to Ath0 and the Bridge0 has LAN and WiFi as the components.

    The WiFi is just set as an Access Point in the interfaces menu with a type of None.

    Thanks again for the help.

    Steve



  • @Honeybadger:

    Nothing tell me that I have to reapply except that my LAN is unreachable after a reboot.

    When I reboot the unit, I can only contact the network through WiFi, LAN is unreachable.

    Have you explored why LAN is unreachable? DHCP server not running? LAN IP address is wrong? System you are attempting access from has wrong IP address? LAN interface is "down"?



  • Nothing is down, everything is at the same settings that they were at before the reboot.

    Just makes me re-apply then then go to the serial and apply the same setting again and everything works till the next reboot.

    Sounds like I have everything set and it's just a weird behavior of the new PFsense version.

    This was working perfectly when using 1.2.3…



  • @Honeybadger:

    My bridge members are LAN, WiFi.

    I had my wired network as VR1.

    Right now my WAN is VR0
    My LAN is bridged and my WiFi is ATH0

    How should I assign them?

    Bridge members should be VR1, ATH0
    LAN should have bridge assigned as network port
    Like explained here http://forum.pfsense.org/index.php/topic,20917.msg128389.html#msg128389



  • Thanks Jameson,

    I read that pinned post but under my bridge members my choices are WAN, LAN and WiFi…I don't have a VR1 or a ATH0...



  • @Honeybadger:

    Thanks Jameson,

    I read that pinned post but under my bridge members my choices are WAN, LAN and WiFi…I don't have a VR1 or a ATH0...

    Ok, the problem is (I think) that LAN interface has bridge assigned as network port, and is also a member of that same bridge.

    Look here https://picasaweb.google.com/carlarsen/19Aug2011?authuser=0&feat=directlink

    The bridge (network port BRIDGE0) has IF_ATH0 (which is network port ath0) and IF_EM0 (which is network port em0) as members
    The interface named LAN is assigned network port BRIDGE0



  • Ok, I am trying to follow you but keep getting my PFSense server locked up…

    Ok, when setting      up my pfsense, I have:
    WAN set to VR0
    LAN set to VR1
    WIFI set to Ath0

    I am trying to set to set up a Wired set to VR1 (so I can set LAN to Bridge0)

    Should I set to Wired to be static with an IP like LAN is currently?

    Thanks,



  • @Honeybadger:

    Ok, I am trying to follow you but keep getting my PFSense server locked up…

    Do you mean you lose access to the web GUI? or the whole system locks up and you can't even get a shell prompt on the console?

    I reorganised my interfaces something like what was described in the linked reply but that was some months ago and I don't recall the details but I do have a recollection of seeming to lose access to the GUI at one stage (fixed by a reboot).

    @Honeybadger:

    I am trying to set to set up a Wired set to VR1 (so I can set LAN to Bridge0)

    Should I set to Wired to be static with an IP like LAN is currently?

    bridge members should not have an IP address - the bridge interface has the IP address.

    How far along in the procedure in http://forum.pfsense.org/index.php/topic,20917.msg128389.html#msg128389 did you get?

    Do you have a spare port on the box you could use to access the web GUI? Or could you temporarily access it through the WAN port? I think there could be some unsatisfactory interactions happening when you change the LAN interface while trying to access the GUI over the LAN interface.



  • Thank you, Thank you, Thank you all!

    I did have to go back in to the serial interface and assign my IP to my LAN one last time but everything is working now even through a reboot…

    I could figure out how an interface without DHCP assigned could be the VR for my LAN and reassigning my LAN away could be correct but with all of your encouragement it seems to be working!

    Thanks again! Wallabybob and Jameson, thanks for sharing your knowledge and time!


Locked