Network driver "Atheros AR8151" Missing! Please add it!



  • My old hardware finally died and now I'm trying get my spare system running,  an Asrock AD525PV3.   This Atom board has the Atheros AR8151 nic integrated into it and of course the second nic is pci Realtek card that works.  I've been trying for several days to figure out how to integrate the drivers, but I fail.   I do know from research that FreeBSD 8.1 does support it, but apparently it's not included with Pfsense.

    Can you all please add it? I really need to get my Pfsense router back up and running, ASAP!



  • If it is present in 8.1 than it is in pfSense.

    Iirc those models need FreeBSD 9 not sure if they will be in 8.3 as well.



  • I tried to follow this "http://forum.pfsense.org/index.php/topic,32664.0.html " , but everything is too vague and complicated because I don't know anything about FreeBSD.  I went from link to link to link for days trying to figure it out and I'm about to kill over due to stress. When I first started Pfsense on the other hardware everything just worked, and it was great.  Switching hardware has made everything a nightmare because I don't know how to install these drivers.



  • Wait for tomorrows snapshot i included the driver referenced in those tickets.
    Though likely is that your driver needs a newer version of FreeBSD.



  • Awesome!  Thanks a lot for looking in to the issue!   Pfsense 1.3 and 2.0 has been running great for the past several years now (until the old hardware kicked the bucket)!   Can't wait to see  Pfsense running on this 11 year newer Atom PC!


Locked