[Solved] Routing issue 2.0-RC3 amd64 latest



  • Hi,

    i have replaced my old Netgear FVX538 with the lastest pfsense 2.0-RC3 (amd64) built on Wed Aug 17 20:38:08 EDT 2011.

    Topology:

    ADSL1
              pfsense1 (.15)
    ADSL2                        
                                      - LAN - Workstations, Servers                      
                                   /        
              pfsense2 (.1)
    SDSL

    PfSense 1 is the workstations gateway to the ADSL lines which has balanced gateways.

    PFsense2 ist the servers gateway. Also there is a site2site openVPN to a outside datacenter. Some clients have to connect via application for mysql access, so i have setup the gateway of pfsense2 on pfsense1 via system -> routing.

    Then ive added a rule for LAN which routes alle traffic for the remote network to the pfsense2 gateway (i have tried this with static routes but this has not worked). The traffic will be forwarded as expected but there are connection losses (like lost connection to mysql and also the interrupt of a ssh session to mysql server).

    When i manually set a route to remote network directly at the workstation (route add) the connection is stable so the problem is not located at pfsense2 or the SDSL line.

    System graphs -> quality on pfsense1 does not show anything which lets point to the cause of this issue.

    So why does the statict route not work but when i define a firewall rule it works, even without static route and why i have this connection lost when pfsense1 takes care about the routing..?

    Any Idea..?

    I have performed the update of the lastes version today morning, yesterday with the eralier version the problem hast not occured…

    Thanks in advance.

    Regards,

    brick1




Locked