Slow Internet Using Pfsense



  • I've been posting questions here quite a bit in the past few months and I have finally deduced after replacing the UTP cable that Pfsense is slowing down our internet connection by around 30%.

    I have connected the modem directly to the switch and have experienced a boost (30%) in speed. When I connect the switch to Pfsense, my speed diminishes greatly.

    The test setup is as follows:

    Modem>Pfsense>Switch>SingleComputer will bite around 30% of the speed.
    Modem>Switch>SingleComputer has the real (+30%) bandwidth.

    The only package that is installed is squid.

    The interfaces are only WAN and LAN. No OPT1. Only 1 ISP.

    Kindly guide me through this. Thanks.



  • Squid is your problem.  Please read some threads in the Packages forum about how Squid can slow down your internet connection if improperly configured.



  • Will disabling Squid fix the slow Internet problem?

    I have checked the configuration at Services>Proxy Server and it's the same as the instructions in the Online documentation of pfsense.

    I have also read the thread at http://forum.pfsense.org/index.php/topic,7186.msg59302.html#msg59302 regarding Squid. How can I edit the /boot/loader.conf in the Pfsense box using a Windows XP computer via LAN? I'm no good with Linux btw.



  • first this is freebsd based, not a linux
    second you can use webui (Diagnostics:Execute Command:Command) or putty to ssh to box
    third if you want to save changes that those exists after updates create /boot/loader.conf.local where you made those changes



  • I have uninstalled squid and there are no changes in the bandwidth.

    Any other advice?



  • What sort of hardware are you running PFS on, and how fast is your internet connection supposed to be?



  • I'm getting around 4.3mbps when I do this setup:

    pppoe modem>switch>windows xp box>winxp pppoe dialer

    However, I'm only getting around 3.5mbps when I do this setup:

    pppoe modem>standalone pfsense 1.2.3>windows xp box >winxp ppoe dialer

    I have tried the following:

    Services>Proxy Server>General Settings>Checked and UncheckedTransparent Proxy
    Services>Proxy Server>General Settings>Checked and UncheckedAllow Users on Interface
    Uninstalled Squid
    Reinstalled Squid
    Disabled Squid
    Changed the DNS for both pfsense and the client PCs

    There were no changes in the seemingly "capped" Internet bandwidth of pfsense.



  • What hardware you're using?



  • Also, have you run the traffic shaper wizard in pfSense or are you doing any traffic shaping at all?


Log in to reply