Change motherboard : no boot



  • Yesterday i've changed my motherboard in my pfsense router.  It used to be an Intel Atom D510 motherboard (intel CPU-D510MO(B)) but i could use that one for something else and i've installed an Intel Atom 330 motherboard (foxcomm 45CSX).  The rest (RAM, HDD, …) stays the same!

    Now pfsense can't boot up anymore.  It stops at the line "ata0 : <ata 0="" channel="">on apapci0".  That's the last line.

    I tried to start up in save mode, but there i get the error "sc0: <system console="">at flags 0x100 on isa0".

    Can please someone help me out?

    HDD : samsung 160GB
    RAM : 1x2GB</system></ata>



  • What version of pfSense are you running?



  • Hi Cry Havok!
    I'm running pfsense 2.0.  Latest snapshot.



  • What's the snapshot version/date? The concept of "latest" changes every time another snapshot comes out so it is largely meaningless.



  • I'm running the ipv6 version of pfsense 2.0.  The last time i did an update was yesterday.  About 4PM.
    Is there any way i can see the version in txt modus or something so i can tell you the exact snapshot?



  • It should tell you in the GUI. Knowing that you did an update yesterday at least narrows down the options for the version however.

    I assume that this is the full version you've installed and not the Embedded or Nano?



  • First of all : thank you for your (very) quick answers!  It's indeed the full version that i use.
    Since i can't get into the GUI, i can't tell you anything about the snapshots i'm afraid…





  • Does your BIOS configure the hard disk controller for ata0 in "Legacy IDE Mode" (or something like that). FreeBSD seems to be a bit sensitive to disk controller mode; in particular doesn't seem to work well with RAID or AHCI. The actual mode names used in the BIOS don't seem to be standardised.



  • I was about to say what wallabybob is saying…

    I ran into some issues with my Atom boxes in terms of which RAID mode to choose, how to handle failures, etc... and in my experimentation, I am pretty sure I ran into the same error as you... mostly, in the case of when I had to drives RAIDed usign the built in RAID functionality (either Intel or ADaptec, in my case just the RAID feature built into the BIOS, not a hardware raid), then switched that functionality off to plain old IDE functionality (I'm using SATA drives). It appeared that pfSense just locked up mid boot... looks like it was looking for RAID controller drivers to initialize. It would just sit there mid boot.

    This is why, I posted a question regarding this matter and what i was doing wrong... the overall response was to use the built-in OS based RAID features... since I could drop the drive into another box and it should still boot... This is what I am doing now for production environments.

    It was also enough of a convincing issues to do the same thing on my Asterisk box.

    Hope this helps.


Locked