Advanced button missing in System/Routing


  • Rebel Alliance Global Moderator

    Ok seems nobody is reading my other thread about this

    http://forum.pfsense.org/index.php/topic,39941.0.html

    But the advanced button is missing on both my gateways.  How do I get it back?  For whatever reason this line is not setting the style to block vs none like I would think it should?  What do I have to set to get it back vs changing the actual code in file?

    system_gateways_edit.php line 404

    
     1) || (isset($pconfig['interval']) && $pconfig['interval'])) echo "style='display:none'"; ?>>
    
    ![advancedbuttongone.jpg](/public/_imported_attachments_/1/advancedbuttongone.jpg)
    ![advancedbuttongone.jpg_thumb](/public/_imported_attachments_/1/advancedbuttongone.jpg_thumb)
    


  • You fail to say what snaps you are on


  • Rebel Alliance Global Moderator

    My bad.. here current build

    2.1-DEVELOPMENT (i386)
    built on Fri Aug 12 16:23:11 EDT 2011

    With gitsync as of this morning 8/22


  • Rebel Alliance Developer Netgate

    Is it still broken? What browser are you using?

    I just updated/synced a VM and I have the advanced button.
    2.1-DEVELOPMENT (amd64)
    built on Mon Aug 22 10:47:17 EDT 2011


  • Rebel Alliance Global Moderator

    I just did a gitsync this morning, I can run another one here in a few minutes if I see any new commits.

    Using firefox, but can try whatever browser you want.. Give me a few minutes and will check it out and update this post.

    edit: ok still showing last commit I see was from yesterday "Fix field name label." so my sync of this morning looks to be up to date.

    Firefox 6, no button.

    IE8, no button

    chrome no button.  Now if edit that line of code and change the display:none to display:block then I see it.  But shouldn't one of those if statements kick off to see the button?  How do I set one of those variables so it triggers?

    Shouldn't the button just always be shown?


  • Rebel Alliance Developer Netgate

    I'm using Firefox as well, and it shows up fine for me on there.


  • Rebel Alliance Global Moderator

    yeah it just doesn't show in either my ipv4 gateway or my ipv6, odd?  I know it use to be there since I had used it to test changing the monitor time from 1 second to 10, etc..  but then I put it back, and when I went some time later after a few sync's and even did a snapshot update its no longer there?


  • Rebel Alliance Developer Netgate

    Have you tried flushing your browser's cache and trying again? Or trying another browser?


  • Rebel Alliance Global Moderator

    As I stated in the previous post edit I have tried 3 different browsers - on different machines now even.  Do they all share the same cache ;)

    if I change the style diplay:none entry in the line I included to display:block then it shows up - which from what I can tell is what that code is suppose to do with those if statements.  But does not seem to be working?

    I wonder why the button would not always be displayed?  Why are there even if statements?

    But yes to directly answer your question I have flushed the browser cache.


  • Rebel Alliance Developer Netgate

    The if is there because if there are advanced settings set, it automatically expands the advanced options display.

    I just pushed what should be a fix for this. The code was a little confusing in that area and hopefully the new version should work for you.

    https://github.com/bsdperimeter/pfsense/commit/28ce79ad0494416f0c62f81e211894525d9ef33c


  • Rebel Alliance Global Moderator

    sweet that fixed it up, so now I see the advanced items.  And my 1 in the Frequency Probe was set.. So I removed this 1 and left it blank for default and now I see the button.

    So I am guessing that the ifs were not triggering on the 1 which was default in the Frequency Probe setting to show the settings, but since items was set even if was the default I was not seeing the button?

    But its working now, I see buttons for both of my gateways again.  And I will play with the frequency probe setting and make sure it then shows the settings, etc. etc.

    But looks good - thank you!


Locked