Port Forwarding with a Modem DHCP Always On



  • Well too bad for me, I cant get cable or a line to my house, but lucky in the last 2 weeks I've gotten wireless broadband. (Not Satellite)

    To the point: I have a modem that is always on, and always running it's DHCP therefore, my pfSense Box will never get the Real WAN, it gets this WAN IP '192.168.0.198' and I have it set to have the LAN IP to /192.168.0.254'. My issue falls under port forwarding. I'd like to make it so port '49152' will be forwarded to a pc on my LAN with the IP of '192.168.0.50' on the same port. But I'm having no luck. So I believe the issue since I've gotten this to work for many people on more practical networks is the fact that my Modem is acting as a DCHP.

    ISP Info:
    XO Communications (DirectCon.Net is the reseller)
    Modem does allow for DMZ and I currently have the DMZ set to '192.168.0.254'

    Thanks for any tips help or comments.



  • The Settings.

    Firewall: NAT: Port Forward
    Port Forward
      If      Proto      Ext. port range NAT IP                                        Int. port range  Description 
      WAN  TCP/UDP  49152            192.168.0.50 (ext.: 192.168.0.198)  49152              P2P –> P2P's PC

    Firewall: Rules
    WAN   
      Proto      Source Port Destination    Port    Gateway Description 
      TCP/UDP  *        *    192.168.0.50  49152  *          NAT P2P --> P2P's PC



  • Looks like your LAN and WAN are configured for the same subnet? This is wrong. You need different subnets at WAN and LAN unless you run a filtering bridge. However, several features are not supported on the bridge atm so I rather would set up different subnets.



  • hoba thank you so much. you saved my network. if you are ever in Northern California let me know I'll buy you a beer.



  • Ok, IF I get there I'll let you know  ;D



  • I tried putting my DCHP Server from the pfSense Box on the '192.168.1.' and left the Modem's DCHP on the '192.168.0.' with the Modem's LAN IP being '192.168.0.1' and with those settings the internet will not connect. I'll play with it some more and see what I can figure out. Thanks again for heading me in the right direction.



  • Try unchecking "block private IPs" at interfaces>wan.


Log in to reply