Failover fails. No default route created



  • 2.0-RC3 (amd64)
    built on Fri Aug 12 15:32:25 EDT 2011 (I think I'm actually on the Aug 24 snap)
    Platform nanobsd (2g)

    I have two WAN, each set as a gateway:

    WAN1: PPPoE x.x.224.55 (default gateway)
    WAN2: static 192.168.6.254

    And one gateway group:

    WAN1: tier 1
    WAN2: tier 2
    Trigger: Member Down

    All my LAN firewall rules are PASS rules and use the default gateway, except the last one:

          • WAN1_fail_WAN2 none

    My expectation is that when WAN1 does down, outbound LAN traffic should fail over to WAN2. What I see when I physically disconnect WAN1 from the modem is:

    1. System log marks WAN1 as down
    2. Diagnostic>Routes shows no default route
    3. Pings to any non-local host fail with "No route to host"
    4. Pings to 192.168.6.254 are returned.

    I'm not sure why WAN2 is not being automatically configured as the default route when WAN1 goes down. I followed the multi-WAN wiki guide for 2.0 and I don't see my mistake. Ideas?



  • Hi there,

    Is "Allow default gateway switching" enabled?

    Advanced –> Misc --> Load Balancing

    -- Phob



  • Thanks. I did not notice that setting when configuring failover, but it looks like the fix for me.

    Unfortunately, when I turn that on and try to save I get the error "Fatal error: Cannot unset string offsets in /usr/local/www/system_advanced_misc.php on line 119".



  • Hm. the line in question refers to the "Prefer older IPsec SAs" option. Setting it, saving, then unsetting it allowed me to proceed.


Log in to reply