RC1 to RC3 dns problem



  • Hi,

    Upgrading from rc1 to rc3 with auto-update some of my pfsenses i have found two problems:

    1- Now there’s a new one dns server (127.0.0.1) that doesn’t appear on “System -> General setup” neither on “config.xml” file . I have problems to resolve local address from my domain with this configuration. I can delete the 127.0.0.1 entry from /etc/resolv.conf and everything is ok but this entry appears on each reboot. I have a fresh rc3 install and doesnt have this dns entry. Does anyone know how to disable that localhost entry?

    2- NRPEv2 configuration is lost in the upgrade, all other packages are upgraded correctly.

    Regards and thanks.


  • Rebel Alliance Developer Netgate

    System > Advanced, on the Misc tab, there is a checkbox for “Localhost inclusion” - that will stop the DNS forwarder (127.0.0.1) from being used as a DNS server.



  • That option seems to have been deleted from RC3 version  😕



  • @ncolunga:

    That option seems to have been deleted from RC3 version  😕

    There have been many snapshot builds labelled RC3 - which one are you using? (build timestamp is on the pfSense home page)


  • Rebel Alliance Developer Netgate

    It didn’t make much sense where it was. I moved it to System > General with the rest of the DNS settings for the system.



  • I only see the "Allow DNS server list to be overridden by DHCP/PPP on WAN " option, I cant see that option on General Setup.



  • @wallabybob:

    @ncolunga:

    That option seems to have been deleted from RC3 version  😕

    There have been many snapshot builds labelled RC3 - which one are you using? (build timestamp is on the pfSense home page)

    2.0-RC3 (amd64)
    built on Tue Aug 2 22:54:59 EDT 2011

    You are on the latest version.


  • Rebel Alliance Developer Netgate

    Aug 2 isn’t the latest, but we’re testing the final release images right now so once the official 2.0’s are out you should be ok. You’re too far behind to have the override option at all I think. It’s there now though.



  • Ok, thank you.


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy