Help! pfSense 1.0.1 doesn't read config.xml from floppy disc



  • Hello,

    I've got pfSense 1.0.1 (CD-ROM platform) running on a client's SOHO.
    Last week they had a power failure and the UPS gave up the ghost before
    a clean shutdown could be performed.

    Fortunately. the client used the CLI interface to save the
    configuration settings to a floppy disc before the power failure.
    Unfortunately, when pfSense boots from the CD-ROM, it ignores the
    floppy disc's config.xml and goes straight to the "configure interfaces" menu.

    I had him verify the floppy by loading it into a Window$ box.  He sent
    me the config.xml that was nestled in the conf/ directory.  A quick
    glance at the file shows that indeed the settings were saved.

    Any clue why pfSense refuses to read and process the config.xml file?
    Any tips on how to force it to read the floppy?  I'm having the client
    format and prepare a USB mass-storage device with the same directory
    hierarchy as the floppy, in hopes pfSense will successfully read
    that device.


    Regards,
    Doug



  • Does it actually try to access the floppy? USB-Storages should work nice btw and are probably more reliable than a floppy.



  • Just tried a USB-mass storage device.  pfSense fails to load the conf/config.xml file from that location also.  The box has a HD loaded with a bootable version of Windows and Windows see both the floppy and the USB drive.  I can only conclude that something in the 1.0.1 CD-ROM version of pfSense is not working when it comes to auto-detection of devices or subsequent reading thereof.



  • Might be related to your hardware. Haven't tested this lately but tested it with the 1.0.1 release before it got released and it is working. Make sure your medias are dosformatted. So do you see it trying to access the floppy on bootup or not?



  • Solved…

    To answer the last post, the box in which we're having problems is the same box that wrote the configuration to floppy.

    The problems was ACPI.  This is an older PII and ACPI needs to be disabled in order for the FreeBSD to:

    1. See the floppy
    2. Do anything with the NICs,
    3. Not get "stalled" messages for USB mass-storage.

    Once we disabled ACPI, all was well

    Thanks for suggestions and help.


Log in to reply